Walmart's New onn. 4K Box Now Available for Purchase


New ONN Box not in stock at all Walmart locations and not available online yet. My locate Walmart was not sure when they were going to get them.

1 Like

We had to go to 3 different locations before we were able to locate one. Make sure you call ahead and ask before heading to the store!

1 Like

Just selling out that fast? Or limited supply?

Walmart’s supply system is terrible. My local walmart staff will say something is in stock, just to get you to come into the store. They are hoping you will buy things just because you are in the store.:-1::-1::-1:

That’s terrible. It’s amazing how many businesses practice deceptive marketing tactics these days.

1 Like

My Walmart had them but they would not ring up so I went through self check out and it worked. Crazy I know.


Went to my local Walmart in Mansfield, Ohio and was able to magically turn my 3 4K firesticks into onn. 4K boxes. Thanks Troy


You got lucky. My local stores still don’t have any, and have no information about when!!

The clerk (young student) at my local Walmart didn’t even know what the ONN was and he worked in the electronics dept.! He did go search where he thought they might be in a glass case. He saw the old ONN and said they were discontinued. As he was looking down in the glass case, I saw they were right on top, about 12-15 of them. You just need to go look for yourself.

GOT my Onn4k, Super Happy w/ it, very impressed how easy it was to customize. Got a great wolf launcher screen. Having a issue w/ Putting Widgets on. System Won’t let me download aptoide from TP Tool
box, Want to get the widgets from Aptoide. Little help please :pray:t2:

I just did what you described on an original ONN box & Aptoide downloaded fine. Maybe look in your Unknown Sources & see if any & everything is toggled on…?

Thanks, but I checked unknown sources and they’re enabled. You did say yours is original device not the new 4k , correct ?

Mine is 4k Android 10 TV…your o/s I believe is 4k Google 12 TV…I’m not sure what all is different. My main suggestion was to clean/clear/pull power on device/router…plugin ethernet/reboot box & router to afford it a clean memory for connecting. If you did that & it still doesn’t see your ethernet connection then I’m not sure what it could be…I’d have to go thru your UI & see if there is some extra setting/s different than mine that could affect it. Hope this makes sense :cowboy_hat_face: