VPN Constantly Disconnecting Solved

Both of my 4k fire sticks were losing the VPN connection very often. I couldn’t get through a show without the VPN failing multiple times. One stick has OS 6, the other is OS 7. One of the steps I took was to install a different VPN service that I subscribe to. One is IPVanish and the other is Proton. They both would disconnect every couple of minutes. Didn’t have a problem connecting. After trying everything I could think of to fix it, I did a factory reset on one of them and just installed bare minimum addons that I use. The VPN stayed connected. When I was confident the VPN was working correctly, I started adding some of the other addons I was using. The culprit was the TDUK debloat tool in the Troypoint Toolbox. I used this tool for a really long time without any issues The VPN failed right after I disabled the functions that were disabled before the factory reset. I went back into the debloat tool and enabled everything except Alexa and shopping categories, but the VPN still wouldn’t stay connected. Once I cleared the data on the debloat tool and removed the app ,the VPN stayed connected. Both of my sticks are now working fine.


very nice process of ellimination :+1:

Did you do a complete list enable or add and test after adding one at a time to isolate the precise one that caused your issue?
I’d sure like to know the exact process that breaks the VPN when disabled.

When I enabled everything except for Alexa and the shopping processes, the VPN still kept on disconnecting. I decided to clear all of the data and remove the Debloat tool from my device. That’s when the VPN stayed in service. I would have started enabling one process at a time if the VPN stayed connected with Alexa and shopping disabled, but it didn’t. I repeated the step on my other FireStick and had the same results.

I had the same issue only it wasn’t TDUK. To be honest forgot which app it was needless to say, problem solved… FOR NOW.

1 Like