Venom not working with Real Debrid

I cannot get Real Debrid working the the Venom add-on. It registers fine, but say not authorized when I start a movie. Yes I already tried Troy’s recommendation of de-registering and try registering with IPvanish turned off. No change in issue. Anyone else having the same problem?
I finally gave up and removed Venom.

i deleted kodi and restarted with fresh install i think that just cleared what was holding me up but it worked

1 Like

We’ve had a lot of people posting recently that forgot real-debrid expires at some point. Double check that first by logging in online. They won’t send you any notification when it expires and there’s no option to auto renew.

As Davduck said above, the failsafe is to just uninstall Kodi and reinstall. Or just wipe the app data. You might be able to just go into the settings for the Venom add-on and clear cache and data for just that add-on without wiping everything from Kodi. I want to say if you uninstall the add-on then add it back it won’t fix the issues because your settings will be the same; they are stored in Kodi somewhere.

Follow up question. Can you just uninstall Kodi, or do you have to uninstall the add-ons first?

@Rkrasman

When you uninstall kodi the addons go to.