USB drive not detected by Firestick 4K max

I’m using a firestick 4K max connected by ethernet with Ethernet adapter and OTG cable
I followed all instructions on troypoint and the drive is not detected.
I tried a second OTG cable and also another USB drive.

Same result not detected
What am I doing wrong

I forgot to mention that I want to use it as external storage

I have been having the same issue on 2 of my FS4KMax devices. I don’t understand why it’s doing that but I have started using my Nvidia Shield until I can fix the problem.

curious as to what brand and storage amount is.

Continuing the

discussion from USB drive not detected by Firestick 4K max:

The key is a Nevac 64G I bought on Amazon
I also tried with a Kingston 4G nothing is working
Very frustating I spent too many hours on this
If you find a solution let me know
I would really appreciate

I have used two different sandisk drives both worked well,this is what i currently use.
SanDisk 256GB Ultra Fit USB 3.1 Flash Drive

First things make sure you format your memory stick on the fire stick itself, with OTG to external storage. If it still will not recognize it try putting it on fire Max storage application, My fire tv, about, storage, and while it indicates that it doesn’t recognize the memory stick, remove it and replace it two or three times and see if your fire stick will recognize it. Scan disk is a better company of memory stick, however I can have them fail on me in the fire stick will not recognize it so eventually I had to just throw it away.

I lost 2 usb sticks just like you did it wiped them out totally then did not show i had a usb attached.

So that’s why I moved on from Amazon besides their prime shipping sucks big time now.if you order much from them you will know what i mean.

1 Like