Trying to setup a x4plus

I’m trying to get a so called brand new x4plus ugoos set up but will not start up. HDMI cables used from another working Nvidia shield same with lan cable and checked power with meter and get 5v did a reset don’t know the process for this box manual is worthless. Unplug power held reset plug in power held for a few released and nothing begining to think it is a defective box any ideas from anyone or someone who has a x4plus would be great

Have you tried unplugging the power, then push in the reset pin and hold it about 15-30 seconds,keep it held in and plug in the box

1 Like

Yes I tried that I think it is a defective box seems like I have done everything two and three times

Not getting much help here because this is a new box and company we are dealing with.
…but I just discovered Ugoos has a Ugoos devices chat on Telegram Telegram: Contact @ugoos_chat_en


Thanks I will it out tomorrow I am sending it back to my friend so he can get his money back. Now I have to wait for the slow boat from China like you and everyone else hahaha. Thanks for trying appreciate the help

1 Like