Trying to Install Cinema HD v2.4.0 ad free

Trying to install newest v2.4.0 ad free version to 4k firestick. I have an external USB Drive connected to firestick for extra app storage(followed Troypoint tutorial). I deleted the old ad free version FIRST, as usual, then tried to install the latest version. Newest v2.4.0 version won’t install, because it says: app not installed. The package conflicts with an existing package by the same name. I don’t see the old version of the app still on my firestick, and even downloaded and ran the latest version of SD Maid on the firestick, and newest v2.4.0 ad free version still won’t install??? I tried to plug my USB Drive from firestick into my Mac laptop to look for any old remnants from old version, but the Mac won’t read the USB flash drive. And I tried from more than one source on unlinked to get newest v2.4.0 version. Any suggestions??? Thanks soooo much in advance!!! And yes, I have rebooted the firestick.

Hi, r.hawks3, the reason u can’t install the new version of Cinema HD is I think that it may be on your external USB drive., I may b wrong but u can give it a try? Take out your USB & plug it in 2 your computer 2 see if it is there, then delete it? If u use your USB 4 external storage as u say, everything u d/l will automatically go 2 that USB?
Jocko

Mac laptop won’t read the Flash drive formatted for the firestick? Shouldn’t the SD Maid pro app on the firestick clean the external storage flash drive also, like I said, the old Cinema HD app not showing up on the firestick anymore, since I deleted it first, before trying to install the newest version?