Troypoint app download problem?

Has anyone else have or had this problem, I think it started 2 to 3 weeks ago
I was going through my apps on my monster box, and I. was heading to my
Troypoint app looking to see if surfshark had a later version than the one l
have clicked on tp app msg. Pops up saying that tp app has an updated version
Do l want to up grade it now, said yes…then l kept getting tp app shut down
do l want to cancel upgrade or retry upgrade…tried upgrade way more than several times same mesg. Tp shut down tried cancel nothing happened went to new update loop… That was problem #1 next l tried opening from tp app,
The rapid apps installer and i got a message stating that Tp was asked to shut down the Rai…watts up wiff that, also my entire tp app is not working, still not working…I. Tried reinstalling tp app site will not let me download app…please somone help me find where l can download tp app… I had to delete it to try reistall…dowloader, did not work news letter from tp not working…web browser not working either…thank you in advance…

You put the answer in your question…the RAI is the same thing as TP App. It is no longer, as Miki’s link shows.


yes that is the message I. Have seen also…but the link to read or get more info
Is not working,even the one that is attached to your message,So does this mean that we can no longer download the TP app…and who ever still may have the TP RAI. Does that mean it will not work? Or will it??? Thank you Miki…