TP Rapid App Installer Problems

I was reading a recent topic that closed on RAI (with a solution). For about a month, I couldn’t download the RAI because I kept getting the message “Sync Of app installer links still running or failed. Please try again in a moment”. I tried every possible variation possible to get it installed.

After reading the message with the solution (topic closed 1 day ago) I tried deleting the data in Downloader and turned off my VPN (VPN was set to auto-connect - not sure if this was an issue). I opened Downloader and used the IP address After following these steps, TP RAI downloaded with ZERO ISSUES! I am now trying to decide if I’m going to download Kodi or go with builds.

I wanted to let you know about the issues I was having with RAI and confirming a possible resolution. I really appreciate the TP Forums and the dedication from TP staff to helping users resolve their issues. THANKS PEOPLE!



Hey Jeff thanks for being a patron and using the search.

This is why troy focus on using the solution option to your topic. This is exactly why.

Makes it easier for people to have their issues solved if when they search and see this they try what worked.

Please use the solution option more often!

I’m so happy to hear you have this issue resolved for you.


Thanks Dracoo. I appreciate your help.


Draco, I just read your reply. I get the same message when I try to use Rapid App Installer. I uninstalled and reinstalled the app and still getting the link still running or failed message. I just created a new post about the problem. Any help will be greatly appreciated.

robie13, have you tried to install RAI with the VPN off? Worked for me after trying everything I could think of. Good luck!

1 Like

This topic was automatically closed after 30 days. New replies are no longer allowed.