Tivimate will not play recordings

I am recording to an SMB drive. I can see the recordings, play them on my PC, I can even use xplore to open them WITH Tivimate. Tivimate, however will not play them from the recordings menu. It will attempt to play with a spinning circle until the error : Filedatasource$filedatasourceexception.
Any ideas ?

I had the same problem. I cleared all the caches on my apps and I’m not quite sure might have been the surf shark not allowed to play the recording. Do a reboot also to make sure it recognizes the drive.

Cleared cache, didn’t help. Finally I uninstalled and re-installed the app. One thing… the selection of the SMB folder went allot smoother this time thanks to help from TXRon.
But no difference. I can create and see the recordings in Tivimate but they wont play.
The only strange thing I noticed is that when opening the recordings with x-plore, it prompts me for pretty much every player app I have installed…VLC, Kodi, even XTreme IPTV player but it does not show Tivimate. Tivimate has full permissions though. I would just let Kodi manage and play the recordings but Kodi wont handle TS files. Its sort of an annoyance for an otherwise great IPTV app. I haven’t come across any official Tivimate ‘manual’ I went through all the settings but I wondered if there were additional flags that could be specified on the playlist. I noticed the last flag is : ‘output= mpegts’ wondering if there are other options.

For my playlist the output is MPEG-TS

I’m using Kodi 20 & that is usually how I play my Tivimate recordings. It plays TS files great.
I have the recordings stored on USB sticks in a folder on the devices that I also have Kodi installed.

I just open Kodi, select TV or movie, Kodi finds the USB stick, then select the folder & the file is there & plays perfectly. This works with the storage whether adopted or not on my ONNs, MeCool KM1 & my W2 stock 10 OS box.

I’ve also used the “Movie Player” player on the stock box & MX Pro and VLC on the ONN & MeCool boxes. (VLC doesn’t work on the stock box.)

In all cases I open the player & the player will find the storage.

I found out how to change the output type from TS to the other option but it didn’t help.
it writes it and sees it in the storage. It just wont actually play back. Kodi also sees it but just says its unsupported media type. VLC and others will play them when opened from x-plore but not when called from Tivimate. Windows opens and plays with no problem. I saw others that had the exact same error but there was never any resolution.

Puzzling…
I don’t change the file format at all.
Kodi 20 plays the .ts files with no modifications for me.

I got it working. I had the share mounted by the the Shield. And Tivimate let me simply use the system picker to choose the folder. I thought I was done at that point.
Ended up putting in the IP address of the server in under the SMB and then selecting the folder. I had tried that before but it didn’t work for some reason. This time it did.

2 Likes

Don’t forget how you did that, write it down all the steps and everything. Because if you forget you may have the same problems again. I have that problem I’ll do something fix it and I’ll forget how I did it and then I got to start all over again!

This topic was automatically closed after 7 days. New replies are no longer allowed.