Tivimate recording issue

There’s an issue with tvmate recording. Whenever I forced stop and clear the cache on TV mate due to some buffering issues, I lose all my recording settings. Now the recordings will still be labeled under recording but it will not record. But I’ve noticed is I’ll be watching the same program that’s supposed to be recording and it’s not recording I’ll go in the recordings, I’ll update the recording by changing the date or just changing one little thing hit the update recording and it’ll start recording in the middle of the program so there’s an issue TV me if you for stop it clean the cache you could lose your recording settings even though if the labels are still in recording.setting.

2 Likes

(post deleted by author)

1 Like

Nah, you didn’t waste the money. I just believe it was read wrong and taken out of context. I actually had to read it a couple times. I misread things several times. It’s all good @AJS1 We’re all human. Mistakes happen

1 Like

I’m having a hard time with TiviMate recording. I have setup recording on a NAS/SMB without a problem. However have failed to setup on a USB drive. The system recognizes the usb drive but when I select the usb and the folder I want to record to it tells me ‘failed to change the recording folder. I have checked all permissions but to no avail. Any help will be appreciated.

What device are you using. You will need to use the System Picker.

This is a huge problem with Android TV/Google TV where System Picker doesn’t work. What I’ve been doing is expanding internal storage with a USB drive. I will have a video for this early next week.

1 Like

I also add usb as internal storage, then use the movie folder.

Usb drive as external storage …then do this

Quote
I downloaded and installed the X-plore app or pretty much any decent file mgr app. Then, I used X-plore to create an “/Android/media/ar.tvplayer.tv” directory on the USB drive. In X-plore, I did a long press on the newly created directory and selected “show details” which revealed it’s full path name which was “/storage/0F2E-1400/Android/media/ar.tvplayer.tv”. Finally in Tivimate, I TYPED this full path name instead of trying to browse to the directory. Browsing to it will not work.
end Quote
amazing what you can do with a usb keyboard and mouse plugged into one of the 4 usb ports on my 4port hub plugged into my box
working great for me on the new Onn Pro

2 Likes

Any android device - in my case the Mi box, the system picker does not respond.

I don’t have a Mi to test out. There are lots of posts in the forum about how to do this. Comtech in the post right above yours gave you one method. I personally use X-plore, access the USB drive, create a Tivimate folder with backup and recording sub folders. Then go to recordings>recording folder>Select folder>click on USB drive>click on System picker on the right and when it opens I go to the hamburger icon on the top left click to open it>click on the USB drive> highlight the Tivimate folder I created and click on it> highlight the “Recordings” folder click on it> down the bottom click “USE THIS FOLDER” then in the popup “Allow TiviMate to access files in recordings?” I highlight and click ALLOW and then back out.
So doing it Comtechs way but creating my own Folder and sub folders, my path in X-plore looks like this > /storage/3BE9-1919/Tivimate/Recordings but in my recordings settings of TiVimate the path shows much differently after using the system picker its:>
content://com.android.externalstorage.documents/tree/3BE9-1919%3ATivimate%2FRecordings
I don’t know why the path is different ,but then code is a huge mystery to me, I just know that’s how I do it.

The problem with Tivimate is that ‘system picker’ isn’t present for everyone, and maybe not for most.

None of my devices past or present ever had the option regardless of which version of Tivimate was installed.

1 Like

This method worked for me. Thx for your input.
It recorded the video but won’t playback. Remain black screen.

2 Likes

See I tried that but recordings fail after 3 minutes every time. Never could figure out why.

Just did another experiment t i v i mate recording. I had a 24/7 channel that was buff from real bad, it had a still screen but buffering. So I record an hour and a half of it. T i v i May recorded the whole hour and a half of buffering. When I fast forward to the recording it would stop at a still picture whatever was present at that time I guess, but I surprised it recorded it. When I left the the reverse alone on a still frame I eventually got the statement and error occurred illegal State exception. However I can continue fast forward and stop it and it’ll show still screen. Very interesting.
To add to this, I would fast forward instead of 1 minute just 10 seconds, every 10 seconds it would go to a still screen like it’s fast forwarding through the whole movie every 10 seconds and show a different frame at that 10 seconds. However when I stop it, go to still frame until the error occurred illegal State exception.
One more addition. When I use the MX Pro player, it would play through the whole movie at speeds I think to two to three times the normal speed of the movie. I cannot fast forward or reverse it. I could just stop it on a still frame.

I tried your suggested method with the new Onn Pro device but am unable to create a folder, in other words the Explore/system won’t let me write. I’ve checked permissions too.