TheTVApp Kodi Addon Working Again

TheTVApp Kodi Addon is working again.

This is one of the most popular addons available for live TV channels.

3 Likes

Tried the addon an it will not open .

I installed this on KODI last week and it wasn’t working however I just reinstalled it n KODI and tried about 10 of the Channels and everything working fine - no buffering. I prefer VOD over Live TV for everything but Sports/News but there’s some really good channels here if you have a Guide and want to watch something live

2 Likes

You may want to try uninstalling/reinstalling the addon…I just checked and still working on my end and I did a fresh install this morning.

I did do a fresh install .

If using VPN, try turning off/on. Your ISP may be blocking access. Also, try rebooting cable modem, router, and streaming device. Using it right now and still working great.

Still not working with reinstall

Try accessing it through your device’s browser without going through Kodi. I am watching as I type on my Shield Pro. I use TVBro as my browser and use Google as my search engine and everything is working great. My Express VPN is enabled using an Atlanta server.

1 Like

No fix for kodi running it. Still no go after complete uninstall reinstall

i uninstall and install 3 times and still have no Kodi, have ipvanish with no problem with my vpn

okay, so the file source is no longer valid for adding thetvapp.to to Kodi. I tried to add it for the first time, following instructions from @TROYPOINT and it says, “Unable to connect: Couldn’t retrieve directory information. This could be due to the network not being connected. Would you like to add it anyway?” When I use the address in a browser, it says, " 404

There isn’t a GitHub Pages site here.

If you’re trying to publish one, read the full documentation to learn how to set up GitHub Pages for your repository, organization, or user account.

GitHub Status@githubstatus>

Does anyone know if it simply has a new source address?