The Crew not working on Kodi 20.2

I just updated to Kodi 20.2 and I can’t seem to get the crew to load up movies. I reauthorized Real Debrid and when I select a movie it just freezes and never goes anywhere.

Any tips on how to get this fixed?

1 Like

It doesn’t feel like a compatibility issue to me. What device are you using, and have you tried it on 20.2 on any other devices yet?

1 Like

Looks to be working now. I restarted my fire tv. Disregard, thanks


I installes Kodi 20.2,with Real-debris and tralts. I used the cman build Superman and Diggz Xenon. After everything was set up when I try to play a movie from crew, fen etc… it shuts my VPN off and goes back to my homescreen/ I have force closed Kodi in application, restarted it and this continues. Please advise me on what I did wrong, I followed Troy’s video to install everthing.

I will readily admit that I am an antique attempting to remain independent, and I don’t know about all the various apps or installs. I usually go online and ask how to and get it done, and that usually works. I bought a firestick and it worked ,then I heard about Kodi, and with the help of this website, I have enjoyed the product a lot. But now after installing Crew, and streaming old movies, I found that I needed to update, and bang! the New Crew doesn’t work. I did install a VPN product and that isn’ the issue. But when I installed the updated Crew, Troy Point told me that to have better streaming I should install the debrid, what is it? Do I need to buy another service? and what is Real-debris and traits? I could use a primer on some of this and maybe you can get grandpa a couple more years without cable.

1 Like