The Crew: add-on fails in Kodi 20.1

I have made a clean installation of Kodi 20.1 on Windows 10 64-bit. The Crew add-on installs but, on running it, this error is shown “THE CREW error Check the log for more information”. I am not sure how to check the log. No entries are shown for Movies, TV, etc.

1 Like

Okay in the crew repo there are Homelander and Ghost, install these and see if these are finding streams, it may be that the Crew isn’t working.

1 Like

I have also been having the same issues with The Crew, however it is in a build.
I’m running Windows 10 and only effects my pc. I run The Crew on 2 other devices and they both work great with The Crew add-on. One is a firestick and the other Android phone. I am getting a .dmp file report on my pc. This is a little bit more information about the issue. The Crew add-on haven’t been working on my pc, for 3 months

1 Like

Stop running the crew out of a build. Use the addon.

Why? The Crew is working fine in the Build I use


The crew is working fine, But troubleshooting steps would be to run the crew addon alone. I know the crew works regardless of where its accessed but to save time the best option is to use the addon its self.

1 Like

Just tried out the crew version 1.1.7 on kodi 20.1 with rd on my own build with 19 addons in it and it’s working flawlessly.


I just tried Crew and Homelander and neither worked.

Also Seren. All on Kodi 20.1 with real debris. Will not load.

Did you check crew version?

Just tried a newer movie in The Crew on Kodi 20.1 and it found 300+ premium sources. Seren too, it works great. Can you uninstall/reinstall the add-on and try again? Maybe even reinstall the repository and then reinstall add-ons.

Crew Version 1.1.7, Seren Version 3.0.0


Check your real debrid. The crew works fine.


Ok. Will do. My Crew version is 1.1.7

My problem is, the source appears to load, but doesn’t. Just goes back to pre-loading. But I will try re-installing everything. Thanks for your time and advice.


I use the add-on by itself and have no issues. Now my Insomniac add-on has been displaying error log messages.

This topic was automatically closed after 7 days. New replies are no longer allowed.

For NON-DEBRID users: Crew and Homelander not loading current content for me, only old ones. TP-Dracoo did not answer the issue a while back, but just thought it was a Debrid problem, which is solved differently. I can’t find an answer for NON-DEBRID users.


There is an answer, i have said it many times. Stop using free sources in kodi as they are not maintained.

If you really dont want to pay for debrid use stremio. Not only have i answered this many times we also have a search that answers this if you did one.

Yes same here for me too , no new streams, i believe it’s a legal issue :confused: