Teatv. mxplayer

Mxplayer will not work on teatv.The only player it will play
is Tlplayer.

It always use to work. I forget the exact method, but you had to reject their player, try to start a movie then choose external player. I’ll see if I can find exact instructions.

  1. Launch TeaTV on your device.
  2. Search for a movie you’d like to see. Select the movie and press Watch Now below the title.
  3. Then choose to Play with External Video Player.
  4. Choose MX Player, and select Always below so it becomes your default movie player.

Same problem here. “Play with external video player” option does not appear.


Ok. So I just installed TeaTv to test it out and it’s pretty easy now I have external USB attached to my 4K Max.
Went to Seeney’s library in unlinked(From Troy’s RAI) and downloaded the ad free version, installed it, deleted the apk, and started it up. Immediately it asked to install the tplayer, I cancelled/refused I then chose a movie to watch, clicked the “Watch Now” under the movie title, waited for sources to load, chose a 1080p and clicked on it, popup opened with choices,

clicked on play with external player, another popup “Open with”

Chose MX Player Pro, selection opened at the bottom of the previous popup,
I chose always, and clicked on it, movie started playing perfectly with MX Player Pro.
Simple as that everyone.


Thnx Miki…you da’ bomb. As soon as I read your last post I did as you instructed and all is good…w/no ads too. Also I went back into the settings and there is now a spot to choose the default player where there was not one before.

Thnx again…