TeaTV and subtitles not loading after the new release v10.7.4

After I applied the new update of TeaTV v10.7.4 the subtitles don’t automatically display even if I select them in Play with subtitles.
When the movie starts, there is no subtitles. If I check in CC, I need to download them.
I need to stop the movie and then go to CC in top right corner and ask to Search sub by name.
Is this a known bug ?
In the Setting, I’m loggin with OpenSubtitles.
Can you re-propose the previous version which was working perfectly please ?
Where can I get the previous version of TeaTV please for my Fire Stick ?

Thanks a lot

Go to the link below and once there scroll down to about the middle of the page.

Teatv v10.7.4r - Download Latest Version Apk For Android (teatvdl.com)

Thanks ! I can see a lot of previous releases.
Do you remember which was the previous version indicater in the HowTo Install TeaTV by chance on the site ?

Am I the only one with the problem where the subtitles are not displayed/downloaded automatically after moving to this new release ?


No, I never have had TeaTV. So, I really don’t know much about it. I just did a quick research to find you a download for older versions.

Thanks a lot ! :slight_smile:

No one remembers which was the previous version used by Troypoint.com on the Howto install TeaTV please ?

How to Install TeaTV V10.7.4 on Firestick, Fire TV, & Android TV (troypoint.com)

Try one you think it is and go from there. I did see this on the TP page.


Apparently the new Teatv version of 10.7.5 was just released today.
I downloaded it but the problem is still the same with the subtitles not being downloaded. Of course, I logged in again on Opensubtitles.com.

I tried to use the link provided with the old version, but now there is 10.7.4 or 10.6 versions but I don’t see the 10.7.1 :frowning:
I search on internet and could not find this old release of 10.7.1.

I don’t know what to do to have the subtitles with TeaTv when I start an episode …

I found a v10.7.3

I don’t know anything about this webpage. I did run the URL through Virus Total, and everything came up clean. However, I would still use caution and check the download before you install.

TeaTV APK Download latest version for Android (modfyp.com)

Edit: I found it! I did run the URL through Total Virus and it did come up with one malicious flag. So be very cautious with this and definitely run the download through the scanner BEFORE you install.

Download TeaTV torrents - RARBG (rargb.to)

Stremio with Torrentio and real Debrid is way better…IMHO

1 Like

Thanks for your help !
I would prefer to avoid installing it you found a malicious code :slight_smile:

Am I the only one to use TeaTV on this forum ? :wink:
Am I the only one with the subtitles not showing like if they were not downloaded at the beginning of the episode ?


Thanks, that’s a great suggestion.
I will try it ! I hope than subtitles work fine with Stremio :slight_smile:

Don’t blame you. Especially, when there are other alternatives out there.

Btw, the v10.7.3 was clean. So you could try that one if you want.

ho, I thought you said that the APK you found came with a malicious flag ? :slight_smile:

Internet Archive has a bunch. Not sure which will work, tho. Just enter Tea Tv APK in the search. You may also want to have the Search sort them by Date Added, also, as there are MANY versions there. Hope this helps. :grinning:

Finally !
I’ve installed TeaTV 10.7.3 and subtitles work !!!

I’ve noticed a change in the Setting menu, there is no OpenSubtitle setup in v10.7.3.
So I believe the setup for OpenSubtitles in the upper release (10.7.4 and 10.7.5) is not working.

I will wait a lot before updating TeaTv then :slight_smile:
I will maybe try Stremio also.

Thanks a lot for your precious help !!! I really appreciate and all of the messages were super helpful !