Surfshark VPN troubles

When switching over to Surfshark after using IP Vanish (both per Troy’s recommendation) has Surfshark caused us so much trouble? Somehow it removed Prime Video from the Firestick 4k that we installed it on & wouldn’t let us re-install it. Also when we would disconnect the VPN, the Home Screen was unavailable & indicated there was no internet signal? Had to uninstall the VPN then restore device to factory default settings. The VPN was installed & set up per Troy’s video instructions & we had high hopes for this new VPN mostly due to Troy indicating it was so great & would block ads. I now plan to ask for a refund from Surfshark & return to using IP Vanish. They are still offering us the same 2 yr discount for their service if we stay w them. It used to be Troy’s big VPN recommendation before this new one came along. Should have just renewed IP Vanish & kept on going. Never had a bit of trouble w them before. Any ideas here?

Not sure what went wrong but surfshark does not un-install programs, never heard of that before.

Doesn’t SS have that feature/setting where if the vpn disconnects from the internet your connection is blocked. I seem to remember that months ago when I tried SS for 2 weeks.


yep, the kill feature and that sounds like the issue


Thanks Brother. Can always count on ya. Have fun and STREAM ON!!!

1 Like

If you ever have a problem with SS. Get on chat live with them. Their customer service is great. They spent literally hours with me with three different people over two days. They will solve your problem.

1 Like

I’m very surprised that Prime Video was uninstalled as I would of thought that would be locked in on an Amazon device and not have uninstall as an option.

Well I know that I have been having nothing but problems with SS for the last little while since I got a Mecool KM2 Plus. I have spent weeks with Client Support at SS trying to figure out why my VPN connection keeps dropping while I am streaming a show. I’ve tried to make my connection static instead of using the default DCHP setting, changed from Wireguard to OpenVPN-UCP etc… It keeps happening and not sure why. Even blew the box up and did a fresh install and it’s still doing it. I’m lucky if I can get through one 1hr show before I have to pause, exit and reestablish connection…because it doesn’t want to reconnect without me going into the actual application… Anyone have any suggestions/ideas? Thanks TP Tribe. Cheers.

Have you tested out another VPN to verify it makes a difference and fixes your issue? I would recommend doing that under the 30 day money back policy. At least you will know you have an option that works. Having to worry daily about a VPN isnt worth the stress. That is why I moved on even though my sub is still active.


Hello @Timelord1791 I had this same problem with IPVanish but it wasn’t the VPN. The problem was that my Internet connection would drop for a few seconds which would disconnect the VPN. Try rebooting your cable modem and router.


Hello @charlieshan first off, thanks for being a Patron!

As others have said, there is no way that Surfshark will uninstall any of your apps.

A few things to try.

Try rebooting router and cable modem.

Try connecting to a different server within Surfshark app and see if that clears up your problems. Also, try using a different VPN protocol and you can change that in settings as well.

If still having problems, reach out to Surfshark support.

If you can’t get it working, ask for refund within your 30-day grace period.

As I always say, some networks and ISPs don’t mesh well with various VPNs. Use the VPN that works best for YOU.

Choosing a VPN is a personal choice. Lots of complaints about IPVanish back in the day and now the same with Surfshark. It all comes down to personal preference and what works best on your specific network and ISP.

Good luck!