Surfshark VPN Not Updated in TROYPOINT Toolbox

Surfshark has a new update for Android 3.2. I downloaded and installed it (I thought)
using the Troypoint Tool Box. It still has version 3.1

Me too! Great catch. How to get Surfshark 3.2 on ANDROID?

To add to that I just tested and all that Google is offering and through the android download on the page is the 3.1. I used the downloader app and google to test still getting the 3.1 and yeah the other member is right uptodown only has the 3,1 as well. We should be informing Surfshark I think??? There website should be able to download the most recent version not just the version that GOOGLE or other wise approves. This is a direct form of control over population when you think about it.

1 Like

Yes send a ticket to surfshark. I have the same issue. The only thing I haven’t tried is to uninstall my app and then reinstall it off of surfshark website but I doubt if that’ll help.

1 Like

Troy’s Toolbox links to the SS download page. It appears that is still 3.1, at least when I did it through my phone just now it is.


I did uninstall and install including from Troypoint so did it a few times. Kudos for sending a ticket to Surshark. I found that I had a problem on my desktop updating so that was with MICROSOFT store as well which I probably should have included in my original eval as to why I made the comment. It took several attempts to get the updated version on my PC and not have it uninstalled.

Should note I was able to install updated Surfshark on my IOS system but not android interesting eh and had to uninstal first.

1 Like

Just tried a live chat with them and I do not like BOT responses so sent a ticket. Did not mention Troypoint but eluded to a trusted social network site that promotes their product and why I chose Surfshark. I asked specifically about Google. And indirectly made the suggestion that the newest updates should be accessible on SURFSHARK>COM as a way now. Hopes this is the best medium response.

Thanks for this info @Franksr I’ve reached out to my contact at Surfshark questioning why the link that we point to on their page here isn’t directing to the 3.2 update.

It could be that this is still in Beta but if it’s not, they may have simply forgot to update that link.

I will chime in once I hear more about this. Hopefully we are pointing to the new release very soon.

Thanks again!

1 Like

Yeah the chat box doesn’t work very good on surfshark. I usually send a ticket to the email directly to them and they always respond and it helped me out before.

I think :thinking: the apps should have a an update button as part of the UI… ESPECIALLY the apps that we pay for :grimacing: i mean, the app knows enough to tell me-hey-there’s an update-So how about a click to the UPDATE :face_with_symbols_over_mouth:

1 Like

I downloaded their APK file directly off their website last night and it was the current version I already have. I sent them a message as well…

Hi I found in an email received from Surfshark stating the newest versions and each of them are short from the number version. i.e. windows it says : * Windows 5.2.0

  • Android 3.2.0
  • MacOS 4.11.0
  • iOS 3.13.1
  • Linux 1.6.0
  • Firefox extension 4.3.1
  • Chrome extension 4.3.1
    yet on the apps installed from it gives short of so WINDOWS the version is: 5.1.1 but is actually 5.1.1999 so I am wondering if they are rounding up in number? For sure the Android is not updated to the 3.2 but on my IOS it is updated. Surfshark responded with looking into details and asking questions my location, servers used, types of operating system which is logical in troubleshooting. The copy paste of the email is from SURFSHARK everyone…I am still on it and will keep you all updated.

The TROYPOINT Toolbox is now pointing to 3.2.0. Unfortunately, updating doesn’t work and you will get the “App Not Installed” error. This has nothing to do with us and it’s how they put this new app package together as it must have a different code name.

I uninstalled my previous version which was 3.1.0 and did a clean install of Surfshark VPN through the TROYPOINT Toolbox and it installed 3.2.0.

1 Like

That is what Nora from Surfshark told me as well. Delete it and then install the new apk.


Have you seen any improvements with 3.2.0 ?

I was able to update my surfshark app right off the Troy point tool box. However I had the same issue where the surfshark app would not connect to the internet I had to turn it on turn it off several times disengage kill switch and keep disengaging and engaging the app until I finally got internet back then I was okay. I didn’t see any differences in the app.

Oh by the way Green Bay’s getting their ass kicked!

I ope4ned it today and new 3.2 was available. I have incredibly slow speeds but do not have time today to respond to them. They informed me the email was inaccurate as it is a newsletter.

You have to uninstall 3.1, then go into troy’s toolbox and install the 3.2