Surfshark update not sticking?

I have a message on my firestick surfshark app that says I am using an old version of the app but every time I update and then go through the install I get the same notice to update.

I emptied the cache on surf shark and tried again…but at a loss now. It says I am using v2.8.2.10

Try restarting your fire stick. If the app is working fine I wouldn’t worry about it. You could also try force stopping the surfshark and then start it again. I’ve had some trouble with mine too.

I tried updating 3 times an still have that message .

On another note I believe the updates are just new advertising plugs.

Maybe try uninstalling and reinstalling. Can’t hurt to try.

Tried the restart - no luck.

It is working fine…let me know if someone uninstalls and reinstalls it!

I am having the same issue. I cleared cache to no avail. I also restarted my firestick.

1 Like

If surfshark was sideloaded its possible it may not update. Try uninstalling and install from the playstore hopefully it’ll work fine

If surfshark is sideloaded from reliable source the playstore and others will see it and continue checking for updates. The playstore is generally behind in app updates as vendors must meet their criteria for submission.

I have had the same problem for a few days.I emailed Surfshark and asked this question.about the update nag. They were very helpful.

This is how I fixed my problem.
I reset modem,router disconnected my wifi reconnected. Rebooted firestick but before all this I cleared the cache and data in Surfshark and shut it down then rebooted the firestick1 more time. Logged back and the nag is gone.

Ver shows 2.8.2.10 was downloaded from within Surfshark. same version on my other firesticks and onn stick.

Hope this helps ,I am a senior citizen so forgive my spelling :slight_smile:
I thiink I need new glasses lol

This topic was automatically closed after 7 days. New replies are no longer allowed.