Surfshark Services will still run in the background

I don’t have launch app on startup turned on.

When I close the app I get the message Services will still run in the background. If I go into my services and turn off Surfshark service, it comes back on after rebooting.

I looked for answers here but didn’t find any. It’s strange that so many people are worried about no logs and security, and not worried about this.

Any running service is going to use resources, I’d just as soon not have anything running in the background that I don’t start, or can’t control.

Personally if my VPN runs in the background I’m good. I have mine set to start on boot, and a safety dot as well. I never split tunnel and I never connect without an active VPN.


I split tunnel because I don’t want to be gone and the Wife have any issues with her paid apps she uses. Don’t want to listen to it so I safeguard my life and don’t run her’s through any VPN. Lol


I guess my point was why is the service running if I’m not using it? If I’m not connected to vpn then it shouldn’t be running in the background. And if I manually stop the service, it shouldn’t turn itself on after a reboot.

If you have auto start enabled it will start on every reboot. If it’s running in the background then it isn’t off, all that has happened is you’ve turned off the GUI. There should also be a setting for that. I will never use the internet without a VPN, whether running in the background or running with my GUI open for configuration.


Hello and thank you.

No I don’t have auto start enabled. If I manually stop the service, it automatically restarts after I reboot my computer. As mentioned, auto start is not enamble and is not in the “start up” either.

Perhaps I will contact tech support at Surfshark and ask them.

Thanks again for the help


Its just the nature of the app, to run either in use or in bypass(tunnel) around. Its a monitoring app that normally wants to be run thats what its made to do. I would imagine a forced stop after reboot would always be needed.

Just force stop it. :sunglasses::sunglasses:

This topic was automatically closed after 7 days. New replies are no longer allowed.