Strix stopped working

Does Strix still work? I have watched a lot of stuff but now its not working, when i select something it searches and searches put it never finds any servers to connect to. I tried deleting and installing again but still doesn’t work. Can anyone helo, please

I have never got it to work. Even adding real debrid did nothing. All I can get is their porn. No movies, no series, no live tv. Every time someone raves about how good it is I give it another try. It’ plain useless imho.v

Not at the moment it seem movies and shows are not working however the live section is fine (sports…)

Ok so let me tell ya a dirty little truth. Not all Amazon accounts are the same. I’m Canadian so don’t get all the stuff U.S. accounts get. Strix is in the Amazon app store. So as I can’t officially “own” the app, I can’t use it. No amount of side loading or using “apps to fire” is going to change that. Lets use a more main stream app like “Pluto”. Now I can Download it, side load it or transfer it but I can’t install and use it. I get a “you do not OWN this app:::::” so it will never work on my Amazon.ca registered 4k Firestick. Now this isn’t that big a deal as I then program a Firestick using an Amazon.com account. What do they mean “own”. Well here’s a little trick they do. For every app I get from the app store they send me an invoice. Yes I only get “free” stuff. So the invoice shows a charge and balance of $0.00 . I OWN it, and I can use the app unrestricted. I can’t get that with Pluto, so it won’t install or function. The same goes for a huge number of apps and oddly this issue has never come up in any thread I’ve heard of or seen, but it’s true.

Hey! I am a Canadian as well and other than Prime, I don’t use any “Amazon” apps and don’t want to. My Firestick is side loaded and yes, Strix is on it and (other than it’s problem today), works fine here in Ontario. as for getting the “content” I want on any of my android boxes or the firestick, I have no difficulty watching any show that is out there. The only stuff you don’t get up here is with the paid apps that are location blocked but you still can get the content other ways.

Do you have an amazon.com or .ca account. Cause I’ve been doing this for years and never found any .ca account that allows amazon apps like pluto, airy ,xumo, strix ad infinitum to work, ever.

Both as well a business account however I do not use any (other than prime video) apps. I use others like Syncler etc as I do not have a need for their proprietary crap popping on my screen any time they want. I am not sure why your using their apps whether US or CDN. And yes, I am aware that our CDN content sucks compared to the US versions.

Well ya see that’s where we differ. Amazon prime full on sucks and I’ll be damned if I pay for content I can get for free. I’m not sure what you mean about apps interfering in any way with stuff. I use Ola Tv for all the free live tv I can handle and Stremio for all the movies and series. I also have real debrid. Never any issues. So a crappy app like Strix doesn’t bother me, I don’t use it. No proprietary crap on my stick.

Well i don’t know about Canada but if i use the special code when installing it worked fine BUT for some reason movies and shows no longer work. Any idea on how to fix it, i did reinstall it many times but still nothing.

I’ve had that special code since Strix opened and never ever been able to get anything but porn, even tried multiple vpns, no luck. I never did try and dig deep to find a solution because I didn’t really care. Strix isn’t anything special so I simply moved on to better apps.

1 Like

That is strange because it always worked before, i could see all the latest movies but then it suddenly stopped, i guess I’ll have to go back to Kodi

I had problems with Strix too but a couple days ago I uninstalled and looked up the new redesigned version, 1.1. something. It’s all new and works great. Try that. :european_castle:

I didn’t know that they had a new version out I will have to look for it . Where did you get it from? Thanks

I just went to Troys best apk article and followed the download instructions from there. I believe it’s now version 1.1.6. Hope this helps.:european_castle:

Use applinlinked and library 144. Install version 1.16 and it will work again.

Use appllinked and library 144. Install version 1.16 and it will work again.

Hi I’ve just joined Troy point i loaded Strix on to my fire stick . I went through the different options available. It kept making me do an update ( i couldn’t use it without!)
I went on the adult part of the site now I’m constantly opening my Android phone and there is now a sex site always there when i open my messages email. I’m presuming something is wrong there. Could you pass the message on for other users to beware of this or put up a post I’m new here and can’t find out how to post the warning myself thanks

As far as their update is concerned. All you have to do to avoid the update is hit your back button once and then proceed as normal. Personally, I am not a fan of this service at all. They seem at best iffy. You’d be better off with Pluto TV, Watched TV, Airy.TV, Live Channels, etc… Imo, I just think this Strix is nefarious at best. just my 2¢

Thanks for the advice I’m sure your right.