Stremio Not Playing Links

Before I posted this, i did check ip on past posts. But i cannot find an answer to this particular question.

Yesterday my Stremio app was working fine. But today, when I click on a streaming link from the list on any series or movie, it just produces a black screen and buffers. Or, sometimes, the title just flashes on the screen and does not load.
This includes Torrentio+ Ad or tpb+

I have tried using all the links shown, some with people watching and some at zero.

Is it possible that Torrentio is down?

Tpb+ does play the occasional link.

I am using version 1.5.9 android version.

I have Fibre optic 969gb speed and even with vpn speed of 400+ on ethernet, the issue still persists.

I have set cache to 0 and experimented with all cache settings. Still no difference.

I have tried using built in and also external player.

And now i have uninstalled and reinstalled the app. Still no different.

I have cleared cache and data from the app and rebooted my set top box. Minix u22xj max

Can anyone help, please?

My stremio is working fine this morning. Make sure your VPN is not causing any problems on your download. Also check whatever streaming , internet,service you use.

1 Like

Thank you. Just tried pn my mac. Possibly AD is down. No AD Torrentio links are playing, even on Orion.

Tpb+ seem to be ok.

All other streaming apps are ok.

I will leave it until the morning and try again.

Somebody on another thread said that real debrid is down


No worries. I will wait it out.

Moderator please close this thread.

I have just tried again with and without vpn and it is back up and running. Dont know why but it is.

Just an update on this issue. After i wrote that it was resolved, it still was not perfect. Buffering a long time and not playing etc.

A few monghs ago i switched over to external player (mx player pro) and it worked fine until recently.

Today i turned off external player and it is working without any issue on any stream. Well, not good on Orion as usual, considering i paid for the service. But thats another story.

What is or who is your internet service?

Not sure that will help you as i use a vpn and vary it from country to country, near to where i am located.
But i use True Vision ISP thailand.

I even tried without a vpn for those links with All Debrid and had the same issue.

As i said in my OP, i did try with and without external player. But today using built in app player, it is back to normal

Strange how every other app on my device uses mx pro player as default. And none of them have any issues.

So, somewhat bemused at the whole thing.

1 Like

Just noticed in settings, that server status is now showing " online". Whereas with mx player pro, it was showing " offline".
And yet, occasionally with mx player and server offline, i was able to watch some links.

I was having a lot of trouble with buffering, downloads not being constant, issues with recording, I kept blaming it on my IPTV service then I blamed it on ss vpn. Finally ss had me change my DNS settings and I haven’t even had any issues since. I do have to reboot my router from time to time due to being AT&t. I download is usually 50 to 55 and when it gets down to eight or nine I know my router needs to be rebooted.

1 Like

Thanks for sharing. I use Nord Vpn and have never changed to SS or indeed all the other much hyped providers here on Troypoint.

I also have a dns set up from Nord. But, right now having posted my journey with Stremio, i am just confused as to where the issue lies.

Now, i have reverted back to mx player pro and server status is now online again and most streams are playing.

The one difference between using built in or mx player is : Mx player>slight bufferring for a few seconds and then stream starts. Using built in player> flashing title sometimes for a few seconds and then stream starts.

Tried this with no cache and 2 gb cache as an experiment. No big differrence.

I only include this info in my reply, in case it might help others, experiencing similar issues.

Lately I’ve had issues with my VOD and stremio. If I just let the movie play from the beginning and don’t fast forward stop it it’s okay but if I stop the movie or fast forward then I start getting issues, some buffering and other issues until the movie seems to correct itself and play on.

Yep…Happens to me occasionally too. Maybe the stream is just catching up at that point. I think it also might depend upon the link you choose.

I have also found that some links have increased volumes as well. Just trial and error as we learn the system.

Not sure whether increasing cache size might help. But my abdroid OS is quite powerful and have mine now set to " no cache".

Have you tried settings and full acceleration in HW Decoding Mode?

Not sure if that will make a difference. I just keep trying different things and writing down the various setting changes, to see which one works.