Stremio Audio Lags Video


Has anyone experienced an audio lag problem with Stremio video streaming? I am running it in an nVidia Shield box. Any suggestions?

Than you.

Yes I have experienced it. I’ve experienced it when I’m fast forwarding or rewinding it wash something over again. If I start from the beginning to the end I usually don’t have a problem if I stop it fast forward or reverse it then sometimes the audio doesn’t match the video

1 Like

Thank you! I was going to reinstall it, but I’ll try and see if mine behaves as yours. I am a long time Syncler user, and I love it, but after reading some articles in this forum decided to give Stremio a shot. I liked it a lot, especially because it syncs across all your devices. Usually, fast forwarding or rewinding is essential for me, so we’ll see… I appreciate your kind response!

Yes I get this sometimes. I started using the built in VLC. It has the option to “adjust” the audio timing.

Thanks! I will try that also…

Another issue I have with stremio of course I have the same issue with my IPTV VOD is that I don’t get the subtitles for different languages on a movie.

I have not tried switching subtitles to a different language, but could try and see what I get.

On the other hand, I discovered that choosing Kodi as your external player resolves the audio lag problems, even when fast forwarding or rewinding. The only issue is that Kodi is a large sized app. I tried both MX and VLC, but the lag issue was displayed on both. I could not find any settings to adjust for this audio lag.

1 Like

Stremio has a ton of subtitle addons. Once you have a movie started you can click the “enter” button on your remote to pause the movie and open the header. On the header, on the top right, is what looks like a little keyboard, click on that. This will open your subtitle settings. The various languages that have subs will be listed on the left. Choose which one you want. Don’t forget to set up your subtitle options in the Stremio settings under the hamburger before you begin even playing a movie. gl2u

I do that but then the subtitles stay on all the time even for the english. But I’m speaking about is when I’m watching a movie and it’s in English of course and then it’s a cop show and they end up in Russia and in the Russians are speaking in Russia and there’s no subtitle translating into English. The subtitles are built into the movie but they’re not showing up on our end.

I only activate subs as needed. If subs are set to always on in the settings I turn to off, then just click enter, that pauses the movie, then click that little keyboard on the top right and turn on or off with the radio button top right. When you follow my instructions and are choosing a sub package on the left use English Forced when available. Then you don’t get the never ending subs with description, you only get a popup for the foreign parts.

Are you saying I have to pause the movie every time when the when it’s a Russian speaking scene

Not at all. If you are unaware that a movie has foreign parts then when that happens you can pause and start subs with English Forced. But if I even think a movie has non english parts I start the movie with English forced subs chosen. You only have to turn it on once, not every time non foreign parts pop up.

But when I choose English subs at the beginning of the movie I get it throughout the whole movie like closed caption

I don’t think you understand. Activating subs in the settings of Stremio under the hamburger activates subs for everything. Activating using the upper banner you activate is a per movie only option. Under the hamburger I always leave the Default subtitles set to “Disabled”. The following pic shows the top banner activated when I clicked my enter button as soon as the movie opened. Sub choices on left. Choose English forced if available. Not all movies provide the full spectrum of sub option, so you may not have forced. If no forced then you will get a continuous sub displayed, even for the English parts. Takes a bit of practice, especially if you are unaware that a movie contains non English parts. Radio button top right on/off.

That was the problem. I didn’t have English forced.

1 Like

Hi. Just a quick addition. This is not directly related to the subtitles, but I decided to share…

The other day, I was watching a series that had normally English-speaking characters that were based in Russia. I played a link that had those characters suddenly speaking in Russian without subtitles (the dubbing that was happening was not normal, as you could tell by reading lips). Then I noticed that when one looks at the Orion links, near the bottom of their descriptions they show the languages that are spoken in the stream. I choose a link that showed only English (EN), and that stream was all only in English, as it should have been.

Hope that this helps if you experience that issue…


1 Like