Speed loss @4kFirestick with IPVanish

Hello folks. I have an issue that I hope someone can help me with. I have a 4K firestick hooked up wirelessly on 5g. It is about 8ft from the Archer AX6000. I have run speed test on the Firestick with and without IPVanish. Speed, with the VPN, is around 42. Without the VPN, it is 92. I have seen the post about only needing 25 to stream. However, I must have something set up wrong if that is the case. I have the Analiti app on my phone. It shows a ton of information, and I am positive I don’t understand it all. I don’t see any alerts or anything from the app.

Now here is something else. I have tested on my phone and computer with the VPN and the speed is around 80 on both devices. Here are my speed test results from my computer and cell. Pretty much all of them are with the VPN running. https://testmy.net/quickstats/bloodhound. The speed issue is only appears to be an issue on the 4k firestick when running the VPN. My speed is rated at 100/20.

Would someone please give me some tips on what is happening here?

I would suggest rebooting the stick & router…test again…if same results, change your VPN protocols. Most say WireGuard is best…when I used IPVanish years ago I got best results from IKEv2. Others that use this VPN will probably chime in with other suggestions. GL2U

1 Like

Try changing your IPVanish setting. This video will help you.


Thanks guys. I am still playing around with the settings of IPVanish. Right now I am using OpenVPN, TCP, and port 1194. That seems to be getting better speed. I am also waiting on an Ethernet adapter to hook into the system. My router is capable of IPv6, however I am still trying to figure that out. I did get some improvement from a chat with Falcon. The only real problem is with Network channels. The search continues…

1 Like

I don’t think the older 4K firesticks have the coding for WiFi 6. The new 4K Max have that support and coding.

Thanks, Miki. I will have to consider that.


Update… I have been tweaking my IPVanish setting. I have gotten my speed up to 81 and the live TV shows are playing much better. Thanks Troypoint!


If you don’t mind can you click solution on the post that you think helped solve your issue. This way people will know how to solve the same issue if they happen to get it.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.