Smart Tube Next (STN) : User code is loading

I’m trying to activate YouTube (STN) and connect to my account but the user code is not generating. I’m on the latest version 15.99. I have uninstalled and installed STN a couple of times and that didn’t work. I’m using an Android TV box, Onn. I have rebooted it at least once. YouTube works fine on a normal browser. Also I had been using STN for months with no issues. What else can I do to connect my YouTube account to Smart Tube Next?

1 Like

Here is their official website. https://smartyoutubetv.github.io You can compare versions to yours and see if it’s different. Maybe a login problem ?

2 Likes

When all else fails factory reset

No need to do a factory reset for a problem with one app. That’s like trading your car in because you had a spark plug go bad.

1 Like

Like @Throttlejockey said , download directly from the website. You can also install it using RI as Troy always has the latest version. So you remember where you downloaded the app from ?

2 Likes

I just uninstalled it and reinstalled it from the rapid installer Troypoint app. Still doesn’t work. I also read that it may have something to do with the latest update and the time and the date. I’ve been messing around with time/date but still doesn’t work. I need to also state that the smart tube next app works on another device in my home just fine. It’s the same device the onn TV device. Here’s another thing I downloaded the normal YouTube app and that doesn’t work either. This one definitely has me baffled!

Check the settings on the functioning one and compare to what you did to the second one. Maybe something there.

1 Like

I will try that and post back. Thank you!

1 Like

I can’t see any differences between the two devices and their settings. I’m at a loss if anybody has any other ideas I sure would appreciate it.

Okay something on the device itself is definitely blocking YouTube and YouTube alternatives… I just downloaded newpipe.net and that doesn’t work either. Any thoughts? I really hesitate doing a factory reset because I put so much time in to the setup of the device.

1 Like

Turn off vpn if you have one on or spit tunnel it.

I don’t have a VPN. Any other suggestions?

1 Like

Turn off any ad blockers. Maybe using a VPN would help, especially if outside the service area of a dev. and of course so your ISP doesn’t know what you’re streaming.

GitHub - yuliskov/SmartTubeNext: Ad free app for watching tube videos on Android TV boxes

Solved. I tried one last thing which was rebooting my router and that did the trick. Thanks for everyone’s help hopefully this thread will help someone in the future. Thanks!

3 Likes

Glad you got it sorted :pirate_flag::pirate_flag::pirate_flag:

This topic was automatically closed after 7 days. New replies are no longer allowed.