Shield TV Problem

I got a Shield Pro and a Shield TV on black Friday. Set both devices up the same. The Shield TV has a problem when I select an episode to play and the streams start scrolling down the device locks up. Sometimes it just freezes on the list of streams. Sometimes it kicks me back a screen or two. If I go back into an episode then it gives me a gray screen and freezes. Happens with Cinema hd mostly (have tried various versions), BeeTV and FilmPlus. This is with IPVanish and Real Debrid. Sometimes it works OK for an episode or two. I’ve done a factory reset twice and just loaded one app and it still freezes. I’m thinking I have a bum unit. Bad news is it looks like Amazon won’t give me the option to exchange. Can only return for refund. Crap.

Sounds like you tried everything already and unfortunately a refund is better than nothing.


There’s no denying boxes can be bad out of the box, but it is weird that it only happens with streaming apps that have had major issues for a while. Have you tried other more “verified” apps or legal IPTV playlists? Does it still show signs of messing up even then, or do you think it could be directly correlated to these apps? What about with the VPN off?

1 Like

The only reason I thought maybe it was defective is that the shield pro is not doing it and has the same things loaded and working fine they said unless I’m mistaken

I’m not saying you’re wrong. The evidence points to it being defective. It’s just strange that the issues, even if just on the one box, are with apps that are struggling to stay alive right now. I just wondered about the other apps to see if that may lead us to an issue that might be able to be fixed before he sends it back in for refund.

1 Like

In no way was I implying that I have brain farts all the time cones with age and the crappy med’s I’m forced to take all good. They don’t say what if any other apps are misbehaving would be nice to have more info.:grin::v::sunglasses:

Have you tried other apps than the ones that are misbehaving. As @AMD237 has mentioned try another app if you haven’t and see how it goes

So I tested with IPVanish on and off, Real Debrid On and Off with same results. I get the lock up every one in awhile on FilmPlus and BeeTV. Biggest problem is on Cinema. I understand these apks are not being updated and have issues. I’m trying to switch my wife off the FireTV Cube and onto something less restrictive. She loves Cinema because it marks episodes watched (I think Trakt will do that on Shield?), can resume or start from beginning (most other apks I have set to “Always ask” but they don’t seem to do that). I have been working to wean her off Cinema but since it works the way she wants on her FireTV Cube I’m fighting an uphill battle. I swapped her Shield with my Shield Pro (same cableing) and it still misbehaves. I don’t really think its the Shield but am stumped as to why every version of Cinema I try it does the same thing.

Might want to watch this.

Imho, I think you would better off ditching Cinema. You will be forced to sooner or later anyway.



WEll, thats good to know…I will delete the app now, never used it anyways as it was just a backup.


I would say for those who still use it, just get the safe version, and either use Surfshark to eliminate ads or just deal with them. I don’t see any harm in running the safe version until the wheels fall completely off. But like we have mentioned many times, you are going to need a Plan B at some point.


Soon to be Cinema HD…

TV Scramble

1 Like

So after a lot of testing I determined that the Shield TV is fine. Besides the obvious Cinema drama the other couple apks I thought were not working correctly turned out to be operator error. And on the plus side she did start using FilmPlus and found it does mark episodes as watched and will resume an episode if she leaves mid-way through. Thanks for all the help. This forum is awsome.

This topic was automatically closed after 7 days. New replies are no longer allowed.