Seren No Playable Sources

I have Seren installed on Kodi. I am also using real debrid. When I try to get a movie, I get a message that says “It seems you have no providers installed are you sure you wish to continue.” If I press yes it searches for engines and then comes back with no playable sources found. I tried uninstall and re-installed but no go. Any help would be great. Thanks

Make sure that when you enter settings and enter your RD details and confirm by using the link code entered onto your phone/laptop etc, that you click the " Ok" button, top right of the settings menu, before exiting out.


I thought when installing Seren, you had to install the providers also. I am pretty sure there is a couple of threads on this site discussing that very subject. I suggest doing a search for Seren Addon Setup using the search function at the top right of the page. I am sure you will find a solution on how to install providers for Seren.



Follow the guide, shows you how to get providers installed.


I figured out what the problem is. Troypoint has a mistake on the instructions to installing the provider’s package. It says to type in http:// but this doesn’t work. I changed it to https:// and it worked fine.


Welcome to the community.

Make sure to spell it as its shown correctly or it wont install.


Watched the attached tutorial and that did it. All is good. Thanks for the responses!!!

1 Like