RedBoxTV update

RedBoxTV is now asking users to update the apk to the latest version … 2.5
DarkBoxTV also.
Just go to the website for further instructions.
I have used RedBoxTV to watch, mainly F ox news, CNN etc but it has a pretty wide assortment of channels … U.K, U.S and Canadian … as well as an assortment of other overseas country categories.
Well worth a look for those unfamiliar.

Could you post a link to the site for the version 2.5 I have tried multiple site and don’t see a 2.5 and the one’s I do see and try to download don’t work on a Shield streaming device.

I was able to download on my tablet, but not my device.

This one worked for me.

1 Like

I have also used Rapid Streamz for quite some time with pretty good reliability … same assortment of countries and channels available.
Think I got my last update off of the K. Porteous site … also on the firetvsticks downloads page.

Think I’ll skip that one. :woozy_face:

I found this for android but the version is 10.3 I haven’t tried this in years. The 2.5 I found was for Android mobile.

Hey @PapaS check out the one I posted and see what your results are.

Ok, I finally got the juice on this RedBoxTV apk. They make it near impossible to do that update they display on their splash page. But I finally got cornfigured out.

I could find nowhere on the net for a v2.5 apk download. So, what I did was copied this to my laptop. This downloaded a file to my compute. I then sent the file to my device and used X-plore’s app installer to install.

I tried to install the update over the existing app I had already installed. This failed, so I uninstalled the previous app and then proceeded to install the v2.5 from scratch. This succeeded!

Now here comes the head scratcher for me. As I was watching Fox News on the v2.5 RedBoxTV. I had forgotten I turned off my vpn. When I activated my Express VPN it once again failed to load. I decided to change locations. I tried about 4 in the US, a couple in UK, one each in Germany, Canada, and Mexico, all failed.

I was about to give up and call it a day and uninstall this apk. Then I remebered I still have an active SS vpn. So I disabled Express and enabled SS. Did a quick connect on SS and lo and behold it worked! Decided to try several different servers and even a server in a location where I used Express, and it it worked in all locations.

I will be contacting Express regarding this issue because there is NO WAY I would ever even consider using the RedBoxTV apk without using a vpn.

Now, tbh, I am not certain if all my installing issues weren’t related to my Express VPN being on.

Anyway, above is the download file for the v2.5 and it is working for me so far.

For those that experience issues trying to load programs. Consider changing servers or even VPN subs. I plan on checking if the free Proton VPN will work.

EDIT! Beware and take caution. This apk displays 27 issues found by Virus Total. Proceed with caution and at your own risk!

I finally got it figured out. Took a bit because I think my VPN was the culprit in delaying my success.

That looks better @Miki

Just loaded from that link and comes up with 27 viruses. :person_shrugging:

Below are the Virus Total reports for the url and apk. My ESTA found no threats and Malwarbytes found nothing. I still don’t like the 27 issues detected by VT

Yeah, I think this get’s a quick uninstall!

Yeah, I ran 4 tests and 1 out of the 4 says LOOK OUT! and that is good enough reason for me to uninstall this app. I doubt seriously that I would really use it all that much anyway.

redbox has been hijacked so many times I find it hard to trust any apk related to them. Back in the day redbox was the goto app. more trouble than its worth imho.

1 Like

Yep, wasted waaay too much time and effort on an app that, imho, id clunky and now seems suspicious. I used to have this a very long time ago and at most it was intriguing to me.

I guess if folks who are in need of something like this. Then I would probably look for better and less troublesome looking alternatives. As it is, I have plenty of viewing resources already installed and none display 27 issues.

So I have a Xiaomi android TV box (android 9) and I had the previous version of RedboxTV app that worked perfectly till this splash screen started. I tried to install V2.5 however I get an error. I am using APK Installer app on the TV box. Any suggestions to assist…

Did you try what was posted in one of the comments up above. :point_up: Delete the old one and try.

OK. Happy to give you my 2 cents worth. On both my RedBoxTV and DarkBoxTV (Same except one is dark contrast far as I can tell) I got a screen appearing right after I clicked on the channel icon that said update your version.
I think I got previous versions from Kevin Porteous site, he mods his apks and keeps them bug free. No joy, old version only … went over to Firetvsticks website … good selection of apks etc, but same deal … only the old version. I finally went to the official site and downloaded it to my laptop, and them installed it via a flashdrive. Works fine, no ads etc. The official version is associated with IPRoyal which has an app called … used for sending money I think, and this maybe why it brings up a lot of infections on the android virus app.
When you put your cursor over the android download button you will see that its ver 2.5 … it says 2.2 on the page but they havent updated obviously.
Give it a try.

1 Like

Can’t get it to download

Make sure you uninstall any previous version before you download the v2.5

1 Like