Real-Debrid not working on Kodi

I have used Real-Debrid for a few months. My account had expired and I had not noticed so I went ahead and re-subscribed to it. But now every show that I go to gives me a ‘no stream available’ problem with scrapers. I use Kodi, specifically Ezra. And I have a FireStick, not sure the model number or anything, I got it several years ago. I believe I got the matrix build.
I have gone to the real-debrid website and unauthorized all devices, then went back into Kodi and re-authorized the real-debrid account. I have reset the FireStick and tried to update Ezra, but it was the newest version. It still doesn’t want to work. Everything worked perfectly fine a few days ago before my account expired and I have tried to search here but haven’t been successful in finding an answer.
The only thing I can think to do now and try tomorrow to see if it works. If I remember correctly when I signed up for real-debrid before (the first time I ever had it) it worked nearly right away. Or should I try downloading a different add-on like The Crew which is popular to use? I’m just at a loss.

Hi, It seems you have done the right thing inre-authorising your RD account in Kodi. Have you tried a popular stream to see if that plays? Although it is usually instantaneous when you authorise, waiting a while for the system to catch up may work. Try another add-on as well? Let us know how you get on.

1 Like

First of all welcome to this great community. A little bit extra to set-up ezra, hope this helps.


Are you using a VPN when authorizing your device? If so disconnect it and try re authorizing device


This topic was automatically closed after 7 days. New replies are no longer allowed.