Real-Debrid Links Stop Playing After A Few Minutes

10 days ago, Canada experienced a massive nationwide internet failure by one of our major ISP’s . . my internet was restored after 60 hours. When I tried to resume watching my ‘favourites’ using KODI and sourced by RD, none of the saved items on the 3 Add-ons would play longer than 4 seconds. Thinking I had a KODI problem, I uninstalled KODI then re-installed KODI and all the add-ons and ‘reauthorized’ RD on all the add-ons. Still no success with RD sources. By chance, I went down the list and found the non RD items at the end of the list and they loaded and played instantly. What am I missing here??? I removed and re-added all the devices. Should I have ‘reset’ rather than ‘reauthorized’ my RD account??? Tkx.

Check your subscription time, you may need to renew.

Also my rd was back up after the outage, that had nothing to do with it aside from a modem reset.

1 Like

Tkx . . . Sub good until Nov . . modem reset and reset and . …

RD Customer service unhelpful ;-((

I had a similar problem a couple of nights ago. Tested RD links last night and worked just fine. Maybe another update. Who knows but with RD it’s usually temporary when problems arise.

1 Like

Tkx . . Perhaps someone from RD will read this and a light will go on . . . . :clapper: . .and we’ll get some action !


HARK ! ! ! . .Did a tour thru my 'Fav’s a few minutes ago and RD is now responsive and functioning properly without, as far as I can tell, any additional input from any other source. Or maybe it was just a 10 day buffer? ? ? OR
Maybe it was the treat of going back to cable ? ? ? ? Naaaaaaa !
Thanks again to those who commented.

Glad its working, still no issues as far as i can tell but you never know. Enjoy.

This topic was automatically closed after 7 days. New replies are no longer allowed.