Real Debrid issue

I hope this is the correct place to post this and get an answer from somebody. My issue: when I select a real debrid link for a tv show, it will go to an entirely different show. And iti’s not just one provider, it’s several. Has anyone else had this problem? And I can’t find a place on real debrid to get an answer. Help.

Terry

1 Like

Wich app or addon are you using. Many have complained it happening with Cinema, although I have few problems with Cinema.

1 Like

It is with Kodi. And no stream available is happening much more often.

2 Likes

Wich addon with Kodi?

1 Like

I use Real-Debrid and have been using it with Kodi for over three years. I use it with The Crew, The Promise, and Nightwing. Before that it was Oath and Marauder along with The Crew. I have never had that problem even once.

4 Likes

It sounds like your real debrid subscription time is up or something, because i rarely ever get a wrong link with it.

Make sure your real debrid is up-to-date.
Re authorize your account
Delete your devices in real debrid and re add them
Make sure they are added in real debrid.

These steps are a must and will solve the issue 9 out of 10 times. Also check real debrids Twitter for status updates.

5 Likes

OK, I’m not very tech savvy, so thank you so much for your help. I know it hasn’t expired. I just renewed it just a couple of months ago for 6 months, so that isn’t the problem, But I will reauthorize it and see if that helps Thanks again.

1 Like

You said RD links you tried, so I took it you were up to
date. Let us now what happens.

2 Likes

This is strange behavior if using seren crew and other popular addons with real debrid as they dont typically run into that issue.

1 Like

I’m using Crew and it just started happening recently.

I just now tried The Crew and a few episodes of some of the shows I watch. I had no problem getting links or correct episodes for the shows I wanted. When you reauthorized Real-Debrid did you turn off your VPN? I can think of no other reason it would not bring in correct links or any links at all.

2 Likes

Do you have a real-debird account? If not that could be problematic.

Yea, mentioned above real debird was recently purchased. Something isnt sycing or it needs to be re authorized.

@ctwuest Turn off VPN when you authorize / re-authorize. Turn back of after that.

2 Likes

This happens all the time, not on the “ most popular episodes “, but many shows that involve true crime or crime investigation there’s a good chance you’re going to get “evil lives here”, for example

1 Like

Also, sometimes you might get “no stream available “ while trying a show in “tv calendar “, but if you back out and do a search for that show, it’s quite likely to work

That’s exactly what I am finding with some of the older shows, especially crime related. Thanks so much for your feedback.

I’ve been having similiar issues to the above. The incorrect episode is being returned with True Crime series - Very Bad People, Time To Kill etc. It’s happened with Crew and Seren but when I use Cinema it never happens. I’m not exactly sure how the process works but I was assuming it was mislabelling by the seeders. I thought I’d post in case this is the start of some more serious issue.

That’s the third party after using that’s what it’s searching for nothing to do with real debrid try using Cody it never really doesn’t ever give you the wrong show happens on film plus all the time I hope that answers your question

As of right now Real Debrid is having network issues, use stremio without RD it works fine. RD links are failing there is server issues.

1 Like