Real debrid help needed

I recently uninstalled and reinstalled my kodi to 19. I installed the misfit mods build. However now even though I have put in my real-debris code 5 times the real debris (specifically seren) add on keeps telling me that it is not authorized. I’ve also tried to resolve the URL discrepancies.

Please help!!! I don’t know what to do!

Hi @Speedrcrwi
Can I get a little more info… Device, what version of Kodi.
As for Seren, here is Troy’s video on installing Seren. Just ensure you follow it exactly; especially when adding the scrapers (http://bit.ly/a4kScrapers)
https://troypoint.com/seren-kodi-add-on/

2 Likes

It is a fire tv. I used the Troy point app to load and the misfit mods build walk through. The misfit mods has an add on for seren in it but for some reason even though it looks like it authorizes whenever I try to play a movie through it I get an error pop up that it’s not authorized and I should update my settings.

@Speedrcrwi

Yes you can follow TP manual as mentioned by @Sbrowne126 how to install Seren. For Real Debrid follow the steps :point_down:

Before authorizing your RD account.

First open a browser and login to your Real Debrid account from PC/laptop.

Then click on Authorize Real Debrid from the application, a message will pop-up with the authorization code.

From your Real Debrid account navigate to device a link will open " as shown below" with a field to enter the authorization code you received from the application, few seconds later your authorization will be activated.

Note: Don’t Authorize your Real Debrid from this platform, but open the link from your PC/Laptop when you logged in to your Real Debrid account.

The Device link should looks like that.

https://real-debrid.com/device

1 Like

I did the authorization link about 5 times. The pop up disappears after I put in the code on the website. That typically means it’s successful AND I get a message that says URL resolved. But when I go to play a movie specifically from seren it says there is an error and that I must authorize from settings.

I should point out that I have authorized other versions and even another Tv’s kodi and the real debris works. It’s one kodi app on one fire TV that is giving me this error. It was working previously but I had uninstalled it all to get new updated versions

Have you added the addon package for Seren?

1 Like

@Speedrcrwi

Yes you have to complete the settings process.
After the authorization you have to add the package otherwise it will not work.

Scroll down in this link after the Rd authorization
You will see how to complete the package. After doing that you have to restart Kodi before opening Seren.

Pls view the video all explain how to add the package includes the link, before the end of the video. Also @Sbrowne126 added the link for the package. If there anything else pls let us know

https://troypoint.com/seren-kodi-add-on/

Still nothing. Says I need to authorize

So I don’t get responses for things I have done.

1). I completely uninstalled kodi from fire TV

2). I used Troypoint app for latest stable kodi build.

3). I installed seren video add on using the atroypoing walk through.

4). I then installed the misfit mods light using the triypoint walkthrough.

  1. I see the seren add on be added into misfit mods

6). I authorize my real debrid. The pop up window disappears. And it says authorized.

I then look for a movie. Any movie. I hit ok to find sources but instead I get

Error message. No authorization found please go to setting.

7). I then go into settings and reauthorize via the url dependencies for real debrid

I get the same error message.

@Speedrcrwi

You don’t mentioned anything about installed package which is very important step after RD authorization.

You also installed Misfit Mods Lite build on kodi 19, this build also has to be RD authorized separately. Here is the link from TP manual how to do that Mistfit Mods Build

Important: When you authorize RD the message with the authorization code will disapears, “it means authorization completed”.

Pls. Try again with clean install. I don’t know if you installed Seren inside the build, if it’s already there try check the setup steps and RD authorization again otherwise:

Uninstall then install the Seren Kodi Add-on otherwise you will end with more errors.

Follow up with the Seren installation from the link below:
Seren Kodi Addon Install – Screenshot Guide

After completing the installation scroll down further, and continu with:
How To Setup Real-Debrid on Seren Kodi Addon with screenshot 1 to 18

Hopefully this will help, if there’s anything else about those installation pls post :+1:

I don’t think you can install Misfits before you finish Seren install.

@Speedrcrwi

I found the authorization problem.

No need to install Seren separately. It’s included in the mistfit build.

After Mistfit build installation, if you have earlier installed Add-ons. You should authorize Real Debrid from the top menu bar. If you want to authorize Seren which is pre installed in the mistfit build you have to authorized seperatly from inside the build, from this stage " No Need to Add The Package", because it’s already configured with the mistfit installation

To authorize Seren just follow the steps below.

Open The Mistfit build> The menu bar on the top
Under in the small menu bar navigate, and click on Seren.

  1. Next to Seren Logo scroll down, and click Tools.
  2. Open Settings Menu small icon to the right.
  3. Scroll down to Accounts, then scroll down to Real-Debrid.
  4. Then click on Authorize Real-Debrid.
    Code will show up to authorize RD from PC or laptop.

The problem was when you authorize RD from the main section it will authorize all pre installed Add-ons, but not Seren which this included in Mistfit build.

@Throttlejockey

That’s correct it’s included in the build. No need to installed separately.

@TP-Dracoo this part of the installation is missing in Troypoint manual, and requires attention to complete the installation process.

When installing the mistfit build from TP manual for the first time the part " Choose Misfit Mods Wizard 19" Another prompt with a long list of Settings should appears, but didn’t. “It is not necessary to select anything” But I found this important to choose from the selection to save pre installed Add-ons and settings before Clicking on Continue. To complete the installation process.

This sounded like a good solution as it was different from what I did however I went through all the steps and same thing.

@Speedrcrwi

We cant use those pics on apps like kodi and seren.

Type out the error msg sir.

@Speedrcrwi

Well this sounds strange, because I’ve installed Misfits build according to TP manual, and I followed the steps correctly specially for this topic, and it works for me, with a special attention the part " Choose Misfit Mods Wizard 19" as I mentioned earlier, another prompt will appears to save all necessary settings, add-ons before clicking on continue, and completed the set-up.

After that I authorized RD from top left of the screen, then authorized Seren from the tools settings, and all previously installed add-ons were visible and functional.

I think that the best thing to do is clean install, because you have tried to many times:

  1. Clear Kodi app "Data " not the cache
  2. Install any add-on of your choice if you want, and if you like to install Seren according to TP manual as mentioned earlier this includes the packages.
  3. Install Mistfit build also according to TP manual with spacial attention to the long list that prompt to save before continuing.
  4. Authorize RD exactly as I mentioned earlier from from the first screen top left, then Seren from tools settings.

If anything else you need to know about those installation and settings all mentioned in the topic, and if there’s anything else you can’t find the answer for it. Pls post your comment again and we’ll be glad to help. :+1:

Once you add the code for authorization do you get the second pop up for location(Living room, Bed Room etc.)

No RD doesn’t have anything to do with that. It doesn’t know you may have multiple devices and doesn’t work over a Network to the best of my understanding. You will need to authorize each device

After you insert your authorization code another pop up always apppears. The only reason I know anything about it was I was having problems with Syncler . I could put in my authorization code and it would go through but after I looked at the authorization and it said my access would be limited and it didn’t have the second pop-up. I didn’t realize my real debrid had been suspended. Another time still didn’t receive the second pop-up and it was because I had not logged into my account. When it is working properly you get the box to enter your authorization code then right away the second pop-up location. As far as I can tell it has nothing to do with the authorization it is just part of their protocol and was a tell sign something was wrong for me.

1 Like

@DawgFan1989

When you click on Authorize or on Reauthorize my account a pop-up message will appears with the code.

After authorization the message will disappear.
You’re good to go.

You will not receive a message that’s says your device is authorized.

Here are the steps from TP manual how to sign up and use Real Debrid. Hopefully this will help if you have any other questions pls post them we will be glad to help. :+1:

Ok. Thanks for the info.