Real debrid error

Third time in a week i get error mssg “debrid service returned an error” that lasts several hours on ALL tvs and SEVERAL devices…fire sticks, new ONN, Buzz tv, and other google boxes. Doesn’t matter if VPN is on it off. I tried to find help on real debrid site but it asks for generated link and hoster link and i have no idea what that is. Other apps that don’t use real debrid exclusively besides weyd, like cinema hd, NOVA, Tea tv etc get no links at all or maybe just one so i can’t watch anything. One tv is a new sony bravia. Help please

Just trying to understand a little bit more.

So after a few hours it goes back to working without you doing anything different? Internet working ok? Were you near any storms?

Did you check your account to make sure its up to date?

I’ve had no issues with RD at all and I use it daily. I have noticed in the past month that some major sources have disappeared. But fortunately I have enough addons and scrapers that there are always playable scrapes.

Correct… goes back to normal. Wifi fine…i watch amz prime while it’s doing it. I thought it was real debrid… active until oct. But usually on popular newer shows other apps have tons of links and many are not real debrid, but at these times i got no links on all except 1 on cinema hd. For a newer, last years law and order svu, and blue bloods nothing. No movies have links. Done the usual unplugging, restart, turn off surfshark, nothing. I have 2 tvs and 5 devices, same on all. I’m stumpped

Yes, i thought it was just real debrid but it’s other links also. Never had a problem with rd either until now

I only use kodi so i dont know about the other apps you are using. Rd has worked fine for me.

Sorry i cant help with this.

2 Likes

I think some of the sources are closing down with all the reported court cases, especially those who don’t have top line security or can’t afford it. But the mountain is high and will take more than my lifetime for them to dig through.

1 Like

Hi miki. Im in the uk and have got the same problem as you and everyone else


This is what im getting on my screen from crew. Dont understand what it means :confused:

Tried it without Surf Shark on and off but no difference.

I got a popup in umbrella addon yesterday that real debrid was down for maintenance then a few hours later it was ok.
Regarding your popup, it is wanting to save that file to the real debrid cloud but is waiting on file selection. If you login to real debrid and go to torrent page it should have a popup for you to select files.

How do i do that ive never had this problem before.

Im not sure how to do this as never had this problem.
So dont know how to do it.
Can you send instructions on how to fix it please.

The link that you click on for the video in kodi must not be cached on real debrid. Is there no other links available?

I just tested this exact same show and Episode using the KODI Umbrella Addon and received many 1080P playable Streams. I used The Crew for years and not aware of any issues but switched to Umbrella a few months ago because it is the fastest Addon out there. I suggest either reinstalling The Crew or switching to another Addon. The issue is on your end. Umbrella has playable sources for this show

Sorry i don’t know :confused:

4 Likes

Links seem to be working again…at least the few i tested

A few people ruin things for everyone else. Smh. Glad they limited and got this fixed…now it is “faster than ever”.

Did U change anything? I get all the way to the torrents, pick 1, goes to the page with the picture and the Send request and unlock torrent speed rapidly by then nothing. Stays on that page zooming in and out then just won’t play. Eventually goes back to pick an pick episode. Any clue on this?

Are you using kodi or an apk?

I had no problems with kodi.