Real Debrid down Again

Man, I was hoping for the fast links tonight~alas, RD (again) with issues, as is their site…

The latest newsletter from Troypoint explains the remedy for Real-Debrid.

Real Debrid not working for me still in Cinema HD even after following Troy’s instructions. I am unable to Click the box for “Turn off premium links (Recommended ) even after playing a movie for a few seconds as Troy suggests. Anyone else finding this?

I followed Troy’s fix and get mixed results. Sometimes get Debrid links and sometimes not. I’m assuming Real Debrid’s service is going on and offline as they deal with the issue.

I did the same thing. I followed Troy’s instructions and could not turn off premium links. Not initially and not after playing a movie for a few minutes. None of my RD links are working. And the place Troy advised to turn off, isn’t light up like other contents?

I had to log off my real debrid, also logged off my ipvanish, then I clear cache, and force stop cinema, put real debrid back on cinema, my box was open with a check mark already on it, when I went to settings. I looked up a couple of shows and movies, saw that the links were coming up, and then put my ipvanish back on after. Hope it helps. Mine has been working fine unless RD goes down again.

Hi hbublow. So I logged off RD. Then I turned off ipVanish (couldn’t see how to log off). I cleared cache. I don’t know how to force stop cinema? played movie for a few seconds. logged back into RD, could not turn off premium links. So then I logged out of RD and removed Cinema and ipVanish from my firebox. I then reinstalled both. Kept ipVanish off. Went into Cinema and turned on RD. Played a movie. Could not turn off premium links. Also could not do so with ipVanish back on? Basically, can’t use Cinema at all, because none of the links work. Thank you for the suggestions. Do you or does anyone else have any ideas for how to fix this? (Oh, I did figure out how to force quit and tried that also)

I hate that didn’t work for you. Also what i should have said, was disconnect from ipvanish, not log off. Sorry. Hopefully you get it figured out…

Thanks for your suggestion but it did not work for me either.

I was able to make things work by following Troy’s recommendation…I think the key is going to Settings=>Applications and then “force stop” IPVanish and any of the apk apps that you want to try the fix. It doesn’t appear that it is good enough to simply close IPV or the apps…need to force stop them.

Thank you hbublow and gabengineers for taking the time to help. I really appreciate it. It’s still not working. Can it truly be the order with which things are force stopped or logged off? In doing so again, there was another Cinemax update (2nd in short period) so I hope that didn’t make a difference. I am going to outline my steps again in the hopes that someone has the answer since this doesn’t seem to be working for PaulC either.

So I “force stopped” ipVanish and Cinema on my firetv (bedroom; yesterday I tried on fire cube, living room). I also logged out of real-debrid. When you ‘click’ on force stop is something suppose to happen? I click on it and can’t see that anything happened, maybe that is the problem? Going back into Cinema (sans ipVanish), the menu that says "Turn off resolve premium links (Recommended) is grey, not white, suggesting that link is not activated to be turned on or off? Logging back into Real-Debrid does nothing to turn that link white. Removing Cinema and ipVanish from the fire tv and reinstalling and force stopping and various combinations off–sigh, nothing works. Thanks in advance for any other suggestions!

I’ve been following this topic. I don’t have a solution but would like to add a few comments about what I’ve been seeing on my end. Maybe we can find out something through shared successes and failures that’ll pinpoint the problem. Troy, please weigh in on this.

I updated cinema like everyone else. It doesn’t matter if I check or don’t check resolve links immediately. I get a ton of real-debrid links either way. I tried to “break” cinema by toying with many settings. I get plenty of real-debrid links regardless.

I did likewise with catmouse and cyberflix. I select resolve links immediately, get real-debrid links anyhow. I tinkered with combinations of settings. I always get real-debrid links.

I’m having the total opposite results with unlockmytv. No matter what I do, trying everything that’s been suggested under this topic, I can’t get real-debrid links. Before this situation arose, I was using this app and getting real-debrid links.

Very confusing.

So I will also test Cinema and advise however Xanax (my go to) has been unusable since this issue started. When using “The Crew” while finding links it gives the appearance of having premium links/streams available but gets hung up and cannot complete the process.

Don’t want to be a conspiracy theorist however for those of you that also have IPTV subscriptions know how bad the buffering has been over the last week (s) and I am wondering if there is more to this entire situation - something similar to an Xtreme Codes but also impacting RD as well. For strange/personal reasons I have 4 IPTV subscriptions and all have been lackluster over the last week (ethernet connected, 1G and Nord usually 250 - 350Mbps with VPN on) and I believe Sportz and Sapphire have had “website” issues.

It is an odd time in the steaming world…

hi all, just use syncler, I paid $6.40 for 5 months, most links as long as you subscribe to real debrid are superb 4k and 1080 links. it’s a couple of cups of coffee price at a cafe. I’m sure most of you used the free code given by Troy when this first went live, if that doesn’t convince you nothing will. Hope this helps. Jimmy.

1 Like

I have now deleted cinema hd, because of the problem with REAL-DEBRID, if you have got a VPN there are many good apps you can get full access to in america, TUBI, and others, also check TROYPOINT rapid installer.

Thanks for that update, I am still using Cinema and its working ok for me but I still cant get any Real Debrid links to work despite trying Troy’s suggestion. I do use other apk’s too tho. If this continues unresolved I will not be renewing RD when my sub expires!

My real debrid has been working wonderful with my Cinema. Many many links

Same for me. Working great.

I get many Real Debrid links too but they are all ( need resolve) and when clicking on them I get error message 'responseAddmagnet Error:403. I ger lots of non RD links too and they are working fine!

My Cinema and Catmouse both worked well the morning 12/25 evening no go on either with Real Debrid.
Checking this morning at many across the world reporting problems even tho the website is reachable.