Problems with Youtube and Surfshark combined

I’m using the Buzz 5 (128gb) with Surfshark installed. When I try to launch Youtube, when SS is running, the entire Buzz box shuts down and needs to start from the beginning (bootup?) The only way that I can make this work it to shut down SS and then restart SS in a different city (US) and then launch Youtube. It will then work fine for a day and then this headache starts all over again. I’m running the latest version of SS ( this problem was there also on the earlier version of SS. I have a download speed of about 140mb with the VPN running. Is anyone else having this problem or am I the only lucky one?

You tried to Bypass the Youtube app?

I’m gona go out on a limb and say its the buzztv x5 causing the issues.

This problem is there whether Youtube is bypassed or not.

1 Like

Hey TXRon, you could be right, but I have no way of verifying that because I only have the Buzztv hooked up to the idiot box.

no rhyme or reason to think that just that I have a x5 and many issues with it.

TXRon, I have the same thing, lost of problems and no solutions. My biggest gripe is the every time I restart it, it want’s to start from scrap, I guess they would call that a reboot. Makes doing anything with box a major pain.

My regret with buzztv is that I didnt purchase it from amazon, because if I did it would be long gone. Buying from them direct makes return even more expensive although maybe worth the cost. Lesson learned.

TXRon, I completely agree, I did the same. Bought direct and would of send it back if I got it from Amazon. I just hooked up my firestick cube with Surfshark and it works fine on it. (so far) In this “game” every day brings a new surprise.

1 Like

I just want everyone to understand one thing, alot of these boxes that have custom android operating systems like buzz interface may may have issues with some apps. Apps require a different type of code to make work and it varies on type of os being used.

Firetv googletv androidtv genric android mobile os and any others that are custom to the box may have some system interference. More streamlined apps should work and most versions do work with these apps as they are compatible with all android operating systems. But some can conflict. Report all issues to your vpn provider with device you use and os and see what they say. So far i havent had a single issues with anything android windows or firetv. But i cant speak for everyone. Just keep testing and playing with settings. Also some protocols work better than others on some equipment.

1 Like

Hey Dracoo, thanks for getting back. I’m ok with the problem of Surfshark shutting down my Youtube app. (paid version) I can use one of my other boxes to get around that if I have to. But the problem with the buzztv starting from a “fresh” start every time I turn it on, is a no go for me. All the other boxes that I own do not have that problem. I’m still trying to figure out if that is the norm for this box or is that particular to mine. Can you shed any light on this for me?

Just out of curiosity @johns is your power key definition settings set to suspend. That’s where mine is and it starts up normal.(without reboot)


Hey PapaS, you are my lifesaver. That did the trick. How did you ever figure that out!!! It took me a while just to figure out just where the “power key definition” located. Well worth the search, thank again,


Probably a good footnote to have for buzz users and SS

1 Like

I agree, this seems to be a pretty common question about the x5, especially when one of the updates took away 2 of the options in that setting, 1 of them being the “suspend” option but thank goodness they fixed it after a week so @johns that explains why I knew about it, cause I :flushed: had to put up with that annoying reboot on power up too for a week.


Miki posted to use a Canada server to solve the problem until SS fixes the problem on the US servers.

Its been fixed already.

Only logging into Amazon has been fixed. Still problem with youtube not working with SS.

Hello @rjwinkler YouTube working fine on my end with Surfshark on Fire TV Stick 4K Max right now.

1 Like

Try using smart tube, works with Canada servers, but not US servicers.