Problem with BeeTV

Since BeeTV had its latest update, it no longer works. Not sure if anyone else has had the same problem.

If you open it, you can load it and get the list of TV/Movies and it even lets you go to your favourites, but if you click on any of them, it throws you back out and onto the main page.

Would be interested to see if anyone else has the same problem.

1 Like

What device? There could be another reason. That’s typically a sign of not enough resources or space to run the app.

2 Likes

Just went to mine & it updated to 3.2.0 & tells u you cant update if using a mod version

Also sum versions or devices wont let u use extrnal plyr, so if you dont install their plyr, it may kick you out when you hit play

hth…

2 Likes

I’ve had problems as well. It won’t update. It also only allows me the Titon video player and nothing else. Asks me to install, then nothing works. I’m going to switch back to Cinema unless any other ideas?

1 Like

I’ll download and install BeeTV and run it through it’s paces and see what it spits out. Ok done, installed and using MX Player Pro. Runs flawlessly. Sorry, forgot to mention, this is on a 4K Max. Also authorized RD. Oh and there’s more. I saw I was on 3.1.3 so updated to 3.2.0. That also worked perfectly.

1 Like

Yes, the 3.2.0 update this week (official version on Firestick 4k) has trashed BeeTV. Ads, and slow as molasses. I’ve been able to install VLC as the external player using the usual method but that hasn’t helped the speed issue or ads.

1 Like

Odd. I only got one ad when closing a movie. As I have a mini keyboard hooked into my 4K hub it was easy enough to close. That was on the 3.1.3, no ads yet on the 3.2.0 You are right, it’s pretty slow loading and I don’t see anywhere that any RD links are displayed, but I may just not know how to recognize an RD link in their app.

2 Likes

Nope all good it’s you or you device or provider

Ive done the same, I have gone back to Cinema, which is a shame really as there were some programmes that played on Bee but doesnt on Cinema

I would probably agree if it wasnt for the previous version worked fine.

The thing is, on my Max I installed and ran the previous version, I then updated to the latest version. I used the “official” version. Everything works. External player :white_check_mark: Sources :white_check_mark: RD integration :white_check_mark: Media :white_check_mark:

1 Like

Which is the official version when I go to their site I have a choice of three or four or five different versions

This is the link I used. Download BeeTV APK (OFFICIAL) v3.2.0 on Android & Firestick

I went back into it today and there was a further update, so I am guessing a lot of people complained.

However, as a result of the new update, I am now able to watch things through it, so it appears to be resolved.

I want to thank all of those who replied and tried it and lets hope it continues to work ok.

wooohooo. Good for you. Glad it’s been updated and it works for you.
Have Fun and STREAM ON.