Problem installing latest kodi version on fire stick

I can download the version but it does not install. Same problem with Downloader.

Where are you trying to download these apps from?

1 Like

Through Downloader……Troy point.


You have to hit it twice, download then you will see an orange circle then you can select that it will install.

1 Like

Ok I’m a little lost. You don’t need “downloader” to download and install any app found in the RAI. Can you describe what steps you take and do you get any pop up warnings? In the RAI you simply click the download arrow, then when it’s finished downloading you click the circle with the right facing arrow on the right side to initiate the install.

1 Like

That is exactly what I do. But the install does not happen. The graphic showing it is installing continues to spin. The last time I tried, I stopped after 30 minutes.

1 Like

We need to determine the source of the issue, the root cause.

Anyone know of any logfiles generated that we can examine?

Can you actually download anything using any app? Do the downloads complete successfully?

Are you using any attached storage?

Did you go into Install unknown apps and give the RAI permission to install? Downloader needs to be turned on first, then install the RAI then go back to Install Unknown Apps and turn “Troypoint” on.


I have been using the stick for a couple of years and have had no problems in the past in downloading app. Unknown apps is turned on

There is no attached storage.

Ok. I guess the next question is, which stick. I have the Max and it works perfectly using downloader and RAI as well as any app that allows APK install.

1 Like

Do you have enough free storage? Is this a clean install or an update? If an update, which version are you trying to update.

Not sure how to check which Firestick except that it is a Firestick 3 with 1.48GB of available storage. I am using the latest version of the software for this version.
Currently using version 19.1 of Kxxx trying to go to 19.4

1 Like

If you go into Settings–>My Fire TV–>About it will show Device Type, what’s it say?

This is odd we’re missing something. Can you install anything? Possible Kodi just doesn’t want to do that update.

Have you tried uninstalling Kodi altogether and doing a clean install of the newer version?

Ok so it worked then it didn’t. You need to try to remember what happened between those times, obviously ‘something’ happened.

Any new apps or updates installed (system OR app)?

Either using RAI or Downloader, download an app, do not install it. Once downloaded open a file manager (X-plore is what I use), find the downloaded file and check its properties. Compare the filesize to what’s listed from the source. Are they the same?

I’m just exploring here, remember that as a last resort you can always try resetting your firestick and start from scratch.

One last thought. Power interruptions or spikes can wreak havok on electronic devices. Have you had any that you know of?

Keep giving feedback we’ll figure this out :slight_smile:

Device Type - Fire TV Basic Edition
Have not yet uninstalled and reinstalled KODI.
No changes to anything - system, set up, power source etc.
No new apps or updates
Downloaded an app and verified properties = seem OK
No updates to TV firmware
No power updates or spikes and it is protected by s surge protector.

From what I gather I probably have two main choices -
Uninstall and reinstall Kodi
Reset the Firestick to factory settings.

Think I might try the first option unless I receive any further advise.

1 Like

Reinstalling Kodi isn’t that bad a choice. It’s what I’d do.

Let us know how it goes.

1 Like

Reinstalling worked. Thanks all for your assistance.