Pluto tv App delete after update . Will not reinstall

My Pluto app worked great on my Nvidia Sheild 19 but after I updated to the latest update I lost the app an when I try to reinstall it I get a popup saying app not installed . I don’t care were I get it I get the same result . Im runing Surfshark VP on Chicago . The same before the update so I don’t think its the VPN . I have a 1000 harddrive so I have plenty of space left . Do anybody have any ideas whats going on ?

After the installation did you delete the APK. Often APKs are forgotten and cause issues when deleting the app and attempting a reinstall without deleting the original APK.


The new update deleted the apk . I looked didn’t find it .

Always had trouble finding the right version to work in Canada although I’ve never tried this on the Shield this was the one I had to use to get it to work.

1 Like

I have V 5.21.1-leanback, updated on November 14, 2022

I just checked mine and everything is functioning as normal. Tested with and without VPN

Device: 2019 Nvidia Pro
VPN: SurfShark (Server Chicago)

#1. What version are you running?
#2. Where did you download the app from, i.e. Google Play Store, webpage, 3rd party stores ?
#3. Is this app an official app download or is it a modded app?

I downloaded from google playstore and 3rd party . No mods . It’s the latest version . It’s an official app .

Papas ! I tried to download the file you posted but it faild to load .

1 Like

I would try uninstalling the app. Then unplug your device and modem/router for a few minutes. Then reinstall.

Other than that, I have no idea why yours isn’t working. I have the exact same device and surshark set to Chicago and it installed for me fine.

I checked all permissions and unknown apps and nada.

The app never installed . That’s my problem . It wont install to my box .

Check your security setup. Nvidea might have pulled a quickie when you werent lookin’…I have xumo and pluto bith on my shield and they both integrate into the live channels app to consolidate them all.

Rebooted router and box still didn’t do any good . All of this starter after that last update . Crappy update .

Ok, try this. Go to your Google Play store app in settings force stop and clear cache. Then go to your Google Play Store and try to install the Pluto app.

If that doesn’t work. Go back to your Google Play Store app in setting and clear Data. Then try to install again.

If that doesn’t work. Then try uninstalling the Google Play app and reinstall. Then try installing the Pluto app.

If you uninstall the Google Play app you will need some sort of browser to search on to get to the download app page.

Another idea is to download the Pluto app on your Android phone or tablet. Then using the Send Anywhere app. Send it from your phone or tablet to your Nvidia. You will need to install the Send Anywhere app on both devices.

Also, you could try using downloader to install it and then look in your x-plore app in downloads and try installing it from there.

I just tried all your ideas except the phone . They didn’t work . Thanks for trying .

Hey scooter, If you have a file explorer like ES File Explorer open it up and do a search for APK and any you find, delete them, and then try. You’ve pretty much done everything but I’m still stuck on an old apk for the app you’re trying to install.

1 Like

I went in ES file Exploer their was nothing in their to delete . I have Pluto in Tivimate that works good . I like the app better thats why I tried to get it back . I guess I have a bug .

Try going to a webpage and download from there. Then open up your file explorer and install from there in your download folder.

If you get no joy. I have used the Send Anywhere app numerous times to send a downloaded app from one device to another. If you have an Android tablet or phone. See if you can download the app to those devices. If you can then you can send the completed download Pluto app to your Nvidia. Then open your file explorer and install from there.

It’s worth a try if the Pluto app is really that important to you.

Btw, I uninstalled my Pluto app from my Nvidia Pro and reinstalled it from the Play Store and everything went fine. Therefore, I am thinking you have something either in your Nvidia settings or Play Store settings that is blocking the download. I would check those settings thoroughly.

This topic was automatically closed after 7 days. New replies are no longer allowed.