Plex app on 4k fire TV stick can't access PC Plex server contents

Hi. I have been accessing my Plex media server on my PC with the Plex app on a 4k fire stick for 3 years, but this week it won’t access it anymore. I’ve tried all I know, re installed app etc. I can log into Plex acct, but can’t get into my media areas. Does anyone know what else I could try please.

Could you provide more detail so we can try to help? What does it say when trying to access your media server from the Plex app? Does it work from another device other than the Firestick? Could you provide screenshots?

I’m not a plex user but maybe the following could help. As @AMD237 pointed out, exact error messages or codes if any, would certainly help.

I can’t access from any of my smart TV’s either., I do have the Plex server installed on my PC and is working fine, I can access all my plex media on the PC. Please see pic of message on screen when trying to access my Plex media. Thankyou for your help.

1 Like

I have read many of these Plex articles, but unless I’m missing something, it hasn’t rectified the problem. Because it just happened after 3 years, I thought it might be updates causing the issue. Thanks for your help anyway.

There were a bunch of reasons I saw. Like having plex storage on say an external drive and not properly ejecting it and then reinserting it causing the name to change and the route to the files. Lots more when I briefly read a few articles. Also I gave a link to the Plex forum where you can search or post.

Thank you. Everything is on hard drive. I will do as you suggested though.

Plex Media Server Setup Guide for 2024 (Beginners Guide) (

When I get a chance this weekend, I’ll try to see if I can help you get this linked again.

assuming you use windows , I would bet its a windows share issue due to a recent update or a security update…just guessin’

Good point Ron. It has to be something to do with an update, whether it is Plex update or Windows. Out of curiosity @Kamijinga, what version of Windows are you running on the Media Server side? Windows 11?

You could also try their Discord channel…

1 Like

Thank you. The link you added is the way I set it up 3 years ago, with a lifetime Plex pass. It hasn’t missed a beat until now and Plex don’t have any direct support for thier customers now. I have spent days trying to rectify this, at 75 I’m so frustrated, I’m almost ready to delete Plex.

Sorry, yes I’m running windows 11.

There were Plex and windows updates recently, so not sure which is the cause, or if it’s something else.

Please don’t waste anymore of your time everyone, I have now done something and can’t find my Plex acct or log into my server. I can’t get Onto Plex so will delete the lot. Thanks for all your time.

I think if you were to start over, we could get it figured out for you. Sounds like you have a Plex Pass, so to go to another platform may add some extra investment. But if you are sick of it and want to try something different, here are similar apps:

Best Plex alternatives in 2024: Jellyfin, Emby, and more (

My fav is Emby, I run it on my own mini server.

Thank you for guys for all your patience. It took hours, with many repeated installs of Plex server program, but it is now up and running on my TV’s and 4k stick. Very weird the way it instantly corrected itself. Anyway thanks you again…

1 Like