Oath streams not playing

Hi I am having issues with Oath TV series specifically Spitting Image, it used to find and play episodes in season 2, but now it doesn’t find any streams at all in series 2 yet it shows the latest episodes?
Season 1 is working ok, and it finds and plays other TV series no problems.

I have updated the addon and still the same, I am using Kodi 18.9 on a 4k firestick, also on an Android tablet both the same.
Is there anything else I am missing to add on?

1 Like

Is your cache cleared out? Might not have enough room left. Are you using Real-Debrid? If so, is your subscription expired? Those are the only solutions I have. I use Oath in Kodi 18.9, but on an android box with lots of memory space and have no problems at all. Sorry if this doesn’t help.

Thanks for replying,
I don’t have debrid , yes I have cleared the cache, I have tried installing it on kodi 19, I have uninstalled it, reinstalled it and still the same?

I’m showing quite a few links for S2 episodes.

You should really try Real Debrid. It’s the best $3/mo you’ll ever spend.

1 Like

It’s ok I can look at them in Magic Dragon instead…


This topic was automatically closed after 30 days. New replies are no longer allowed.