Nvidia Shield remote - pairing issues

Has any fellow shield users had recent experiences with the remote intermittently losing BT connection with the shield, requiring a reboot to re-establish?

Battery life is good.

Every now and then, while either in use or when trying to wake, the remote will have lost connection. Going into the remote settings, it shows the remote as not connected. Re-pairing from settings does not detect, but reboots will always fix.

Just curious if anyone else has had these struggles.

When the remote loses connection, other remotes, like my Rii, continues to work fine…verifying that the shield itself isn’t frozen.

I’ve seen this about 3 times since getting the Shield. Once with factory remote and twice with 2nd(look-a-like)remote. And after reboots they just started working. No idea the cause.

Looks like quite a common issue with many shield owners on reddit. Many say it happens to them once a week and a reboot is the commonly accepted fix.

Interesting thing is that I never had an issue until the last month or so, with no obviously changes in the landscape.

Yep, ive learned leave the batteries alone :joy:

There seems to be widespread belief that the shield has an unusually unstable Bluetooth stack. The 2019 is improved from the 2017 but still “weirdly” inconsistent.

There may be some heightened sensitivity to EMI that can cause this - but it’s just theory. My shield is pretty close proximity to 3 external magnetic HDDs, my AVR, and xbox. I may try to isolate the shield away from some of my other components and see if it helps.


With my TV mounted on the wall I use a 6’ hdmi cable and the shield sits upright about 3’ away from the tv. I do have the fan on for max cooling but I honestly can’t even hear if it’s running. Shield Pro just plugs rightvalong, although it never truly gets run hard as I never use plex or record.

Shield Remote Won’t Pair And Just flashes Repeatedly.

Was going to start a new topic and did a search for something similar and this thread came up. Even though no solution was given.

Anyway, I was experiencing a similar issue as what @mthr1 posted about and was about ready to order a new remote. I decided to do a bit of research first and glad I did!

Here are some directions posted in another forum regarding this very issue. I followed the 1st set of instructions and it worked great. Now my remote is re-paired and functioning as normal once again.

Side note: After completing the #1 instructions and my remote paired properly and after I rebooted my device. I didn’t even lose any of my remapped button settings.

Anyway, here are the instructions.

1. Using the shield app to navigate, go to Settings>Apps>>see all apps>show system apps> then select “Bluetooth”… clear data and clear cache… then restart your Nvidia shield

2. Factory reset the remote (requires some dexterity). Remove one of your remote’s batteries. Hold the select and home buttons while you put the battery back in. Keep holding until you hear a beep. It’s reset.

3. Go to Settings>Remotes & accessories>Add Bluetooth Accessories… Hold the center button on the remote until it blinks. If it still doesn’t pair. Then hold the remote within 1 foot of your device and try again.

My solution was a bit different…

I took apart my pro, blew out all the crap out of the blower fan and blew out the heat sinks and stuff on the board…

Haven’t had an issue with the remote since…


I’ve had a lot of rain lately and experience a whole bunch of weird stuff last couple of date, internet no connection, lost BT connection, Tivimate app UI went bonkers, dropping ADB commands.

Then last night I lost all internet connections on TVs, phones, tablets, and laptops. Messed with that stuff for about 2 hours searching out the culprit. Finally got it all back up. Then this morning for no apparent reason my Shield remote took a dive. I tried to re-pair but it would not connect. The buttons just repeatedly flashed. It was just with that one remote. My Shield phone remote, tv remote, and my other Shield remote all worked fine on my tv.

I think you are correct in that the Shield BT is the issue.

Anyway, the remote is working fine now and maybe by deleting and resetting the data may have cured the issue.

Btw, I did call Spectrum last night and they said there were no outages in my area.

Spectrum is pretty good at alerting me to neighborhood outages that affect my address.

Your issues last night can come from isolated wiring quality issues caused by the rain (short between the pole and your premises, a short or grounding issue at the distribution block on the pole that your run comes from, etc).

You should run a connection diagnostic from your modem and see what errors or t2/t3 errors that may have occurred last night.

…maybe short intermittent power issues caused by the rain?

Yeah, something weird is going on. Even my stove a few days ago for no apparent reason started beeping that the clock needed to be set. I didn’t think much about it at the time, but now I wonder if maybe my device, modem, router, Tv, and stove are all on the same circuit and it may be corrupted in some way. This has only happened once in the year and half I have lived. Except for the remote not connecting periodically, but as you did, I would just do a reboot and the remote would connect.

If you were getting intermittent power flickers, this would cause your clocks to blink and reset.

Those power flickers can be destructive to electronics.

Up here in the back hills. Utilities can be a bit sketchy.

1 Like

Hell, here in the city, it gets sketchy just as well. :yum: