NVIDIA SHIELD OS 11 Update to 9.1.1

I have gone away from Firestick 4K.

I have recently purchased a new Nvidia Shield running OS 11 and I have just updated it to the new 9.1.1 version.
Since then I have been unable to install any additional apps to the device using both Google Play Store and Troypoint Toolbox via Downloader.

I even did a factory reset to no avail as still no app is being installed but the .apk have been downloaded and are sitting waiting to be installed but I don’t know how.
Is there anyone had the same problem and managed to get it sorted?

I’m starting to think this is not so hot a device after all.

Nobody that I know of here has ever had this issue. There’s always a chance of a bad box, but think you need to try some things before you say it is the device’s fault. Assuming you allowed the installation of unknown apps? That setting isnt default with the Shield.


You have to go into the app settings and allow downloading from unknown sources for each individual app. You have to enable it for downloader specifically. It has nothing to do with the hardware, it’s an OS thing. You also want to turn off play protect. This has been covered in many guides on here for third party apps.


1 Like

I have followed all these directions but I was still getting the same results. I then went down a different route to give it a try - I removed my microsd memory card from the device and rebooted. (My sdmicro memory card is a NUiFLASH Ultra 512GB Micro SD Card with Adapter High Speed Card Class 10 512GB Memory Card for Android Smartphone,Digital Camera,Tablet and Drone 512GB Micro SD.
I was successful in installing a couple of apps to the internal drive. I re-inserted the Memory card and reformated it as external storage. I then elected to move some apps to the external drive. I found that some of these apps did not have the icon showing but a com. file name. I tried to move them back to the internal drive without success. I have now removed this external card by ejecting it and physically removing it from the device. Some of the apps that were on the drive are shown as no longer installed but appear to be downloadable on Google Play Store and I tried one and was successful. I also was successful from Troypoint Toolbox - except for one which keeps coming back saying unable to install (Even though it was installed at the beginning of using the nvidia shield & on the FireStick 4K). I’m not sure if problems seem to be tied to my use of this sdmicro card. Can it be too big for the device to read and if so what would be an acceptable microsd memory card to use?

Look in your file manager and see if they are there. I f so, use the file manager’s installer to install.

Also, not all apps will or can appear in your favorite and app page. If you wish to make a shortcut for those use the TVApp Repo app.

Also, go into your storage and migrate apps to your internal shared or vice versa. What fike manager are you using?


I have X-plore installed but ES File Explorer and ES File Explorer Pro were installed on my sdmicro memory card…

Unfortunately I got so exasperated with this drive I re-formatted it as FAT32and I no longer have any files on it.

I have a data recovery program running on Windows 10 but I don’t know if this will work with an Android disk.

I have a list of apps that were on the drive and I am going to attempt to install them back onto the Nvidia Shield.

I’m not confident that this drive is worth using to add to the device?

I might go for a 64GB or 128GB - any thoughts?

1 Like

I have 256 GB Sandisk drives on each of my Nvidias and they all work fine.


Thanks for that. I think I will be going down that road and see how I get on.
On a different tack - I am able to download apps without the microsd drive to my Nvidia Shield with the exception of the Aptoid TV App from troypoint toolbox, downloader, unlinked with all sources coming back saying that it cannot be installed. Could there be some file left on the device for the app that is conflicting with it and if so how can I identiy it so that I can delete it?

This topic was automatically closed after 7 days. New replies are no longer allowed.