No Sources will Play

After as long as I have used Kodi I am embarased to ask this question.
Using Firestick 4k
Using Exodus Redux.
Selecting Movies.
Debrid enabled.
Trakt enabled
42 Sources 4k, 1080, 720 etc.
Select 1st choice.
All that happens is, it will run down the whole list but None will play,
Then No Stream Available.
I have tried 4 different addons and get the same problem.
I have tried all the settings familiar to me.
I will say it has been some months since I last used Kodi (9)


Which kodi version are you using?

Are you using kodis internal player?

Clear app data try again?

Uninstall re install.

Try 18.9 lea with crew and debrid and seren with debrid. Also use orion scrapper with serens built in. (It’s a provider package) Also try different packages.

I started having problems with Exodus a while back so I deleted it. I now use The Oath and the 2 mentioned above.

Use Kodi 19.
Use MX Neon Pro player.
I started with The Crew, all same problems.
Will try your suggestion with 18.9.
Will try Seren.
Not familiar with orion scraper.
Thanks for the help


I’m suggesting it as kodi 19 seems to have issues with other addons. It’s like the addons aren’t updated with it.

I’m seeing different results on both versions.

Real-debrid expired.


Ah I keep forgetting about this. I check my expiration date is shown and I check mine.

I assume others do as well.

1 Like

I use Kodi 18.9 Lea still have Xanax working.exoduse works great on it

Thanks. I have this showing up on Seren while trying to watch squid game.

Last night I couldn’t watch squid game because seren couldn’t find sources. I’ll check real debrid.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.