No Links w/ Real Debrid

I have been using Cinema HD or Cyberflix with Real Debrid faithfully for a long time but now all of a sudden neither is giving me any streams (RD or otherwise). I’ve uninstalled and reinstalled and cleared cache and data and everything (VPN on VPN off) and it won’t display anything. I either need an alternative app or some other troubleshooting ideas. Thanks

*Also, prefer standalone app as opposed to Kodi.

Hi @cwhiatt
Check your subscription at real-debrid and make sure your subscription hasn’t expired.

1 Like

It is good through February 2021. Also, no streams are coming up. If it was RD only I’m thinking there’d still be other streams.

I just tried Cinema on my mobile device and logged into RD as well but only a couple of streams came up (I tried a few different shows and movies) and no RD streams.

February 2021 was 10 months ago.

Just found a weird glitch on my parents fire stick. RD streams weren’t playing and re-authorizing the account didn’t work. I actually had to delete the account and add it again. Then everything was working again. Very strange.



Was the firestick recently updated by Amazon?


Fed 2021 is long gone check again.

Don’t think so. I’m 99% sure I blocked updates when I initially set it up for them a few months ago.


Okay, I was just curious if the update broke some code. It happens alot.

I think the topic creator needs to check his sub time and then also try this. But if no updates then that’s strange, unless rd or kodi had a soft update that nobody new about.

I turned my Update Blocker off a couple of days ago due to some “odd” behavior and there were 3 updates that installed, one was a major one and the whole process took a half hour. Everything is running smoother but I have noticed RD doesn’t seem to have many sources for vod any more and mine also had some links that didn’t play. I’ll try what J suggested.

1 Like

RD has hundreds of sources if your add-on is configured correctly. Preemptive termination should be off. Provider timeout should be about 30 seconds. Maximum number of sources I increase to about 500. In the case of RD overall the links either work or they don’t. Deleting the account and adding it again fixed my issue. I’m seeing hundreds of links again for each movie.


Unplugged the Modem and Router, the fire stick and killed the VPN and uninstalled both Cinema HD and Cyberflix and then started everything over. Looks like there are some RD streams now.

1 Like

Well I just did it in my VOD apps and damned if it didn’t work. Dozens of RD links populated my source list within seconds. Tx @Jayhawks659

1 Like