Nividia shield Remote not Working

I have a Nvidia Shield pro. The Remote stopped working and won’t pair. The remote from my Sony android TV is working with it which is not what I wanted. Does anyone know how to fix this?

Try replacing the batteries and then go into settings and try to pair again I have never heard of the remote going bad they last along time . If that doesn’t work try doing a search on this site and online for a fix hopefully this helps good luck :crossed_fingers:

I have tried all that. I’m wondering how my tv remote got paired to it. Only my son could do that. Lol. I do like the shield. I find it’s similar to a firestick just wish I could pair the remote

Another option that I have used is going with an all-in-one remote. There are a number of options depending on how “connected” you would like your home to be (along with a wide range of costs). For us I use Harmony (Logitech) vs higher end/more feature sets as I like turning on the lights myself the old fashioned way :grin:. I have a combination of the Elite and Companion models for all of our TV’s and they work great. You can program a ton of activities (music, Shield, etc) and programming is easy and the customer support is great and 7 days a week (at least prior to CV-19).

Happy streaming and good luck

You can use the remote app on your phone too. Try to “unpair” it then add it again once you put fresh batteries in. Go to shield settings > remotes & accessories > shield accessories. You should see SHIELD remote 1. Click on it and go down to forget accessory.

1 Like

Hey all…


Do the shields come with a gaming controller?

Thanx. . Z

The Shield Pro does not. However, you can pair a Sony Playstation Game Controller with it if you have one.

Only if you buy that bundle. I was able to pair an old PS3 controller with no issue.

Thanx gunner…

Just thought for the price they might be throwin in somethin shmancy…

& yes my ps5 will hookup to anything…

My sheild remote will sometimes not turn anything on. I have to unplug power from the sheild then plug it back in and wait on it to boot up. Once it does, the remote works perfectly.

I have tried that as well. I’m thinking maybe I should take my Sony tv of my network. It may be what’s causing the problem.

Did you try going to the link I sent you and look for help from Nvidia

Yes I actually did all that first pretty much everything. I thought maybe someone might have had the same experience on here

I guess it was the shield itself wouldn’t even show up my wifi. Hopefully I get one from support

Had the same problem with a friend’s shield - turns out he had installed 2025 batteries instead of 2032’s

Was it an Older model?

Hi @FireStreams
Not sure if you got a solution to your remote won’t pair/connection issue?
If not, give this a try:
If your SHIELD remote won’t connect with your SHIELD, follow these instructions to connect SHIELD remote.

If SHIELD remote is charged and still does not connect, restart SHIELD and repeat the instructions.

If SHIELD remote still does not connect , follow these steps.

You can also learn how to setup and use the SHIELD remote for the first time.

  1. On the SHIELD Home screen, select SHIELD accessories .
  2. Select “Forget all accessories” > “OK.”
  3. Repeat the instructions to connect SHIELD remote and your other accessories.
    If this doesn’t work, I got nothing else, might be time to contact Nvida support.
1 Like

I did contact support they say it’s the shield itself as it won’t show any wifi networks that are available.


Yes 1st gen. Not sure if that is your problem but it was his and an easy fix. Good luck.

I use a firestick 4k remote on my 1st gen n/shield