New 4k Max Won’t Load to USB

I purchased the new 4k max fs. It shows the usb memory in my fire tv but no side loaded apps will load there and if I eject and reinsert the usb drive into my adapter, a message pops up which says limited access, fire tv can not access apps on this usb device. The usb drive is a new sandisk 32 gb usb drive. I tried 2 older usb drives with the same. I have used expanded memory on my older 4k max fs without a problem.

The access permisions issue is something that has been discussed. AFTVnews has addressed this with how to fix it using ADB commands but unfortunately Amazon has not released an update addressing this issue and I have not seen any info if or when they will.

1 Like

Yeah new 4K Max huge disappointment only positive thing is huge storage expansion but pretty much everything else about OS8 is full of glitches should have waited awhile to buy until they fixed it 3rd gen cube is best Amazon device by far much more powerful and easy storage expansion

1 Like

So very true @alone. No idea why Amazon rushed these new Max to market. But it’s all about money. Huge bill to develop and bring to market. So rush them to production and let the masses trouble shoot them. Then patch them. Bad strategy imho, but seems even Google is going that way.

1 Like

well roku, apple, and amazon devices are the most popular streaming devices so as long as people keep buying them at the rate they are unfortunately amazon can do things like this and it won’t matter people love companies like this and won’t hold them accountable for shitty moves like this.

So very true. The big problem is, most of these huge companies are all doing pretty much the same thing, just in slightly different ways. Google isn’t any different than Amazon. But this is all old news. We have to choose our poisin and learn to adapt.

That holds true with a lot of USA products. Look at general motors and ford. They’re having so much problems with their trucks here in California it’s ridiculous.

1 Like

So is there a fix for this? I have a usb drive that is showing, but I can’t move apps over to it. I formatted it, and now the problems. Before I did that, I had Kodi 20.3 installed, and now it has totally disappeared from my apps. I tried to update to 20.5, but Kodi still doesn’t appear in my apps. I dont know what mistakenly I did.

Nothing’s changed since October.

Happy anniversary @AJS1 :tada:

Took me a minute to figure out what that was. LOL