My android tv box

I have a Nvidia tv box. Let it upgrade to version 11. It acted weird for a few minutes but after a short time, it worked normally. I have a KM2 in another room. All of a sudden it went crazy. I don’t know what happened. All the apps that came pre installed on the box still worked ( youtube, amazon prime etc: ). But all the apps I had installed on a flash drive stopped working. Every time I click on one to open it, it just flashes and won’t stay on. When one does open, it asks me to sign up or log in all over again. My Tivimate app just comes on and and goes off. Anybody got any idea what is going on. ???

No idea, are you on a vpn?

Did you try moving it back to the device and try starting? I would also delete one that isn’t too relevant, download again and open to see what happens

I will say this. I spent all day trouble shooting a mecool box that would randomely flicker…blink off and on…external apps disappear on screen… and after all that it was my hdmi cable. Changed it out and all is normal again. :grimacing:

Been there…discovering a bad cable after spending mucho time on everything else will definitely make you go grrrrrrrrrr…& teach you to check the simple things first. :roll_eyes:

As far as Jesse’s problem…not sure how a Nvidia upgrade would affect a MeCool box…unless it was somehow downloading it too… :thinking:

1 Like

I don’t think it did. I was just surprised at how soon after the Nvidia stopped acting crazy, the KM2 started. Thanks.

Hadn’t thought about the cable. Will change it and see what happens. Also, I don’t use a vpn because I was told that I didn’t need one with the location device I use.

Ha ha…I was being kinda’ tongue n’ cheek…but ya’ never know…

Guessing the flash drive is your problem…throw a couple of apps on your internal & see if they work. Altho, it also could be a faulty port/connection…? Good luck…

Can you transfer to your internal drive. Apparently the new android 11does not give permissions for apps and devices to access external storage.

I discovered a common problem with new streaming devices is that they don’t recognise Apps or Addon’s on external storage. They only “see” them if they are installed onto the storage via the new device during setup. You could try hooking up a new “formatted” flash drive and then install additional Apps or Addons, see if they work? You would need to configure settings again and link RD etc, but worth a try?

I believe the issue is with the new Android 11. It seems that Android 11 is not allowing permission for apps to read external stored data. So, any device that has Android 11 installed may encounter these types of issues. Apparently, Google also has a hand in this turmoil!

I am not certain if moving these apps to internal storage will fix the issue or not? I guess there is a complicated way you can roll back to previous OS, but it is not recommended for the faint of heart, lol

Device companies and app developers are frantically researching hotfixes, patches and generally scrambling to find any kind of work around.

I am not certain about any of this info. This is just some convos that are going around the net in tech groups.

1 Like

google is not your friend


I thought I was the only one that felt that way !!!

1 Like

I did try changing the HDMI cable. It didn’t make a difference. But no harm done. If I had thought of it, I would have tried it anyway.

I had three apps that I had to uninstall and reinstall before they played correctly again.

This topic was automatically closed after 7 days. New replies are no longer allowed.