MXPLayer Can't play this link

My firestick was working well until today. Now all I get is can’t play this link for any app. I’ve uninstalled and reinstalled MXPlayer, tried it with and without the vpn. Don’t know what else to try.

Where are you trying to play links from?

Rapid Streamz, Red Box, Live Net Tv, dark box

Ouch. So none of your apps will play any streams? Or do you have RD and those streams aren’t playing?

None of them will play any streams. My husband was trying to watch a college football game and nothing. Just see the word buffering and then can’t play this link.

When using your VPN have you tried switching server locations?

Are you there Grandmax2

just trying a different location and same message

Have you tried using the Silk Browser and see if you can get any live streams from or

will try that now

This is very odd. I’ve never seen that many apps that won’t work all at the same time. hmmm. I have to do some research on this.

One other suggestion is to uninstall mxplayer and just use the native fire tv player and see if that works.

1 Like

tried that too and nothing

I’m not getting anything from the 2 sites you suggested

1 Like

I have no suggestions at this time. I’ve never heard of a Max having an issue like this. I will do some research.

The sites don’t even load?
Try that then choose a channel. VPN on.

Ok thanks. Cinema, TeaTv and Bee all seem to be working, it’s just the live streaming that is a problem

Ahhh. ok. Live stream not working. I’ll get and see what happens when I try.

ustv wants me to load nord vpn. it started then stopped

Try a few channels please. That site sells Nord so some channels have that notice. I want to see if Amazon’s own player will stream live tv.