MX Player Pro Fail

I tried to download the MX Player Pro from the Rapid App Installer after uninstalling the standard MX Player. As it tries to install I get a message saying “App not installed”. Tried it several times and no joy. What am I doing wrong?

That message usually means that there is a previous version of the app already installed. Did your existing version definitely uninstall before downloading new one ?

1 Like

@PaulC yes I did go back and check that to make sure it was gone. The other thing I was wondering if the file was too big for the available storage space. I have most stuff on an SD card but with the Amazon bloatware there isn’t much space there. I’ll try deleting a few things to see if that’s it.

Sounds like a good idea. Good luck !

I tried installing from Downloader and it seemed to go OK. I launched Cinema and went into settings to change from Cinema Player to MX Player. Went to a random streamer and hit play. Got a message saying “MX Player Not Installed”. Go to Manage Installed Applications and it is there. Shows as Version 1.30.6. Also MX Player shows as an App on my recents. I wasn’t sure it was supposed to show up as an app…
Not sure where to go next.