Movie won't play

I am currently running the Diggs build which most of the time works great. Occasionally, though, I’ll search for a movie (usually using the Movie database) and when I find valid links and try to play, I’ll get the message Movie failed to play, please check the log. This happens whether I try to play using Seren, Venom, Oath or Crew. Anyone else had this issue and where do I find this log as I’ve tried to search for it in settings, etc.

You can install the log reader. I think it’s in the kodi Add-on repo. So I went to Install from repository>All Repositories>Program add-ons>scrolled down to Log Viewer for Kodi.
Now you can also install Kodi Logfile Uploader if you have someone or somewhere to send the file to to get help. Otherwise just reading the log won’t help much.
You may also want to read the following as it gives info as to why some movies won’t play even though you have sources and it may be your Resolve URL.

1 Like

Unfortunately, that link wouldn’t open


What device? Also are you using a paid service or free?

Its a MeCool device. I am using links under either paid or free

Are you using kodi 19.3? With updated build? Try using just crew or seren with real debrid see what happens.

When it finds the movie I want, I have tried finding links using Seren, Venom, Oath and Crew and the same thing seems to happen. Keep in mind, the majority of movies play great. It’s just occasionally this happens. I believe I’m using the latest Kodi version.

I also am running Real Debrid

Odd that you can’t open that link. If you’re on the mecool then clicking that link should open a browser and take you to a site explaining how to resolve your issue and give you info as to why it might happen.

I did finally open it, I just eliminated the first part of it with Google in it.

I was on my home computer, too, not on MeCool

That also may help you understand why you have this issue. I know it’s a lot of reading but the more you learn the easier it gets.

Unfortunately the links in this article seem to have expired

No they haven’t. I can click and open any link.


Also take a look at the link and movie you are playing. Look at the decoder settings, meaning is it acc av1 265 265 that kind of thing, kodi will play almost anything but your box might not be able to play some codecs.

I would imagine most mecools can play alot of hardware codecs. Try using a different program to see if it plays on there and not kodi.

Stremio. (Use a vpn with this)

1 Like

Type in and see what happens. This website is apparently currently offline

I clicked the link you provided as I am trying to learn about these things. It opened but looked like it was just tech data?

Check to See if ResolveURL is Installed

Certain repositories have already added ResolveURL to their offerings. If you happen to have one of these installed, chances are ResolveURL is already present on Kodi. You can perform a quick check to make sure it’s there, if you like. Just follow the steps below.

Go to Kodi’s home menu and click the gear icon then choose System settings.Scroll down to the gear at the bottom left side of the screen. Click it until it says Expert.Scroll back up and select Add-ons, then look for the Manage dependencies entry on the right and click it.You’ll be taken to a new screen. Scroll down the alphabetical list and look for ResolveURL. If you see it and there’s a check mark beside it, the dependency is already installed and ready.

ResolveURL is there, but I just want to be sure I have the latest version

I didn’t even get that, actually