Mekool KM2 Plus issues

Hi all… recently purchased a new box to replace my FS 4K and decided to go with the Mekool KM2 Plus Android TV 2Gb/16Gb.

Liking it so far, but have found that it displays everything darker than my previous devices as well as it is taking longer for shows etc… to start playing.

Is there something I can do to fix this or am I just being too OCD since it isn’t performing like my previous devices.

I have turned off HDR as my TV I am using it with is not a HDR model.


Thanks to someone in another post that mentioned this. But try going into settings>>advanced settings>>display>>screen resolution. Make sure that under “HDR Policy” it says “Adaptive Hdr”. At least that is the pathway in my KM1 Deluxe (4/32). Not sure you want to turn off HDR either.

Not sure why it would be slower. My Mecool is faster than my firesticks or other boxes. I also place my box on it’s side or on an angle to help it stay cool (even though haven’t had a problem with that).


Thanks. Will give that a try. Cheers.

This topic was automatically closed after 7 days. New replies are no longer allowed.